Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3166

Token listing all triggers of a build

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: email-ext-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Along with the available content tokens in hudson, is it possible to have
      something that would return the initiators name. I.e. if we have a hudson user
      database and when someone initiates a build, along with the configured details
      in the e-mail it would have been better if we could see who has initiated the
      same without actually logging into the Hudson, with the help of a token.

      Well, in case of scheduled build it can return scheduled or something of that
      sort. When a build is initiated on demand then if we could see who has
      initiated in the e-mail itself, it would have been helpful.

      Thanks & Regards
      Sun_Pady

        Attachments

          Issue Links

            Activity

            mdonohue mdonohue added a comment -

            The changes put in for issue 291 should be helpful for this

            ashlux ashlux added a comment -

            Committed changes for 2.6.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : ashlux
            Path:
            trunk/hudson/plugins/email-ext/src/main/java/hudson/plugins/emailext/EmailExtensionPlugin.java
            trunk/hudson/plugins/email-ext/src/main/java/hudson/plugins/emailext/plugins/content/CauseContent.java
            trunk/hudson/plugins/email-ext/src/test/java/hudson/plugins/emailext/plugins/content/CauseContentTest.java
            http://jenkins-ci.org/commit/26330
            Log:
            [FIXED JENKINS-3166] Add a token that shows the cause(s) of the build concatenated with commas. "N/A" is used if the cause can't be determined.


              People

              • Assignee:
                ashlux ashlux
                Reporter:
                sun_pady sun_pady
              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: