Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31710

view-job-filters plugin, Regular Expression Filter by SCM Configuration, doesn't work when filtering "Freestyle projects"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
    • Environment:
      Jenkins 1.636 with view-job-filters plugin 1.27, subversion-plugin 2.5.4.
      OpenJDK Runtime Environment (rhel-2.5.5.3.0.1.el6_6-x86_64 u79-b14)
      Apache Tomcat 6.0.36
    • Similar Issues:
    • Released As:
      2.0.1

      Description

      Probably related to JENKINS-29991

      When using the view-job-filters-plugin with a "Regular Expression Job Filter" filtering by "Job SCM Configuration", the filtered job list doesn't show projects of kind "Freestyle Projects".

      I created a view filtering by the SCM url "./mobile/." (just an example), then I created two projects: a "Maven project" and a "Freestyle project", both with exactly the same SCM configuration (we are using subversion here).

      After that, I noticed that my view just listed the "Maven Project".
      Just to make sure, I changed my "Maven Project" configuration to another SCM repository and then the job was gone from the list, as expected.

        Attachments

          Issue Links

            Activity

            recena Manuel Recena Soto added a comment -

            Eduardo Gonçalves, What is the relation with subversion-plugin?

            dudssource Eduardo Gonçalves added a comment - - edited

            Manuel Recena Soto, I'm sorry, the subversion-plugin isn't related to the bug itself.
            After some research I realized that the bug was caused by a modification in jenkins core.
            I'm removing the reference to subversion-plugin from this issue.
            Thanks for ask!

            svenschoenung Sven Schoenung added a comment -

            Fixed in 2.0.1.


              People

              • Assignee:
                svenschoenung Sven Schoenung
                Reporter:
                dudssource Eduardo Gonçalves
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: