Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31993

Workflow Multibranch doesn't create workspace directory

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: pipeline
    • Labels:
      None
    • Environment:
      Jenkins 1.640, Workflow plugins 1.11, Windows 7
    • Similar Issues:

      Description

      A newly created multibranch workflow job doesn't create its workspace/${proj} directory before trying to clone its repository to find the Jenkinsfile to run. Using Mercurial, the job for the default branch tries to clone the repository to workspace/${proj}/default@script and fails because the parent directory doesn't exist. Symptom:

      $ "C:\Program Files\TortoiseHg\hg.exe" --config auth.jenkins.prefix=* --config ******** --config ******** --config "auth.jenkins.schemes=http https" clone --noupdate C:\Jenkins\hgcache\AD53F80F6916C32F1510B2DC580E2777B26FE751-myjob-myuser "C:\Jenkins\workspace\myjob\default@script"
      abort: The system cannot find the path specified: 'C:\Jenkins\workspace\myjob\default@script'
      

      To reproduce:

      1. Install Jenkins, Workflow Aggregator, Workflow Multibranch
      2. Configure Hg in Jenkins global settings
      3. Create a Multibranch Workflow job from an Hg repository

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Duplicate. Not specific to multibranch.


              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                cjyar cjyar
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: