Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32009

Strings like a path to some file (/path/to_my_file), is been interpreted as the full address for the link of the results of the test

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: robot-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.635
    • Similar Issues:

      Description

      Hil all..

      I'm using robotframework with jenkins..

      In my test case, i need to put in the title of the test the path of the file that i need to checkout, exemple:

      Check file /var/myfile (Title of my test case exemple) .

      But on jenkins, its getting 404 when i'm trying to browse the results on fail test, because jenkins is interpreting the "/var/myfile" as part of the link of the result of the test..

      I try to scape the '/' char with "/var/myfile", '''/var/myfile''' , %2fvar%2fmyfile, //var//myfile , \/var\/myfile

      but still interpreting the "/var/myfile" as part of the link of the result...

        Attachments

          Activity

          dirkrichter Dirk Richter added a comment -

          Is this still an issue with latest versions?  I think it should work now using url encoding %2Fvar%2Fmyfile.

          You can use the link Open log.html as workaround.

          dirkrichter Dirk Richter added a comment -

          seems to be a deprecated issue: no reaction on my suggestions since half a year => close (can be reopened if needed)


            People

            • Assignee:
              jpiironen jpiironen
              Reporter:
              dnl dnl dnl
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: