Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32027

Jobs with very long configuration cause script errors in browser and extremely long loading times (10+ minutes)

    Details

    • Similar Issues:

      Description

      In Jenkins versions newer than 1.593 we see issues with jobs that have a long job configuration when we want to edit/check the job configuration in the GUI. The loading page remains gray and in Firefox we get script errors. IE and Chrome show very long loading time. Sometimes 10+ minutes. The config.xml of such "long" job configurations are over 2000 lines long. Short job configs in comparison have less than 300 lines.
      The message regarding scipt errors repeats or Firefox (or IE) process gets stuck.
      1.593 seems to be the last version which does not show the issue. All newer releases including the LTS and latest and greatest show the same behaviour.

        Attachments

          Issue Links

            Activity

            tklammer Thomas Klammer created issue -
            danielbeck Daniel Beck added a comment -

            Are you saying the regression occurred between 1.593 and 1.594?

            tklammer Thomas Klammer added a comment -

            I did not test all versions, but we don't see the issue in 1.499, 1.580.1 and 1.593. But when upgrading to 1.625.2 the issue was seen. Then we tried 1.609.3, the previous LTS version, but it showed the same problem.

            I cannot tell exactly which version introduced this issue. We are now with 1.593 because it fixes another problem we saw in earlier releases with overlapping text but does not show the problem with the long job configurations like later versions do.

            danielbeck Daniel Beck added a comment -

            Tom FENNELLY Didn't you have a prototype that fixed this issue?

            tfennelly Tom FENNELLY added a comment -

            Daniel Beck Nope, I'm afraid I haven't done anything on this.

            tklammer Thomas Klammer added a comment -

            Tom FENNELLY Is this a known issue and also seen by others? That information would already help me to pacify my customer
            Do you maybe have a link to a reference where the problem is described already?
            Thx a lot.

            danielbeck Daniel Beck added a comment -

            Seems I confused this issue with a different one. Sorry about that Thomas Klammer and Tom FENNELLY.

            Thomas, could you check in your browser whether the issue is related to codemirror?

            braden Braden McDaniel made changes -
            Field Original Value New Value
            Labels codemirror
            braden Braden McDaniel made changes -
            Labels codemirror codemirror configuration performance
            chriscralle Chris Cralle made changes -
            Link This issue is related to JENKINS-27948 [ JENKINS-27948 ]
            chriscralle Chris Cralle added a comment -

            I'm sensing a pattern. Can anyone provide a way to disable codemirror for textarea?

            I tried something with hudson-behaviour.js but no luck.

            danielbeck Daniel Beck made changes -
            Link This issue is duplicated by JENKINS-34472 [ JENKINS-34472 ]
            dariver Darío Villadiego made changes -
            Remote Link This issue links to "PR (Web Link)" [ 14406 ]
            dariver Darío Villadiego added a comment -

            PR sent

            danielbeck Daniel Beck added a comment -

            Fix released in 2.12

            danielbeck Daniel Beck made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            danielbeck Daniel Beck made changes -
            Labels codemirror configuration performance codemirror configuration lts-candidate performance
            olivergondza Oliver Gondža made changes -
            Labels codemirror configuration lts-candidate performance 2.7.2-fixed codemirror configuration performance
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 167500 ] JNJira + In-Review [ 198210 ]
            danielbeck Daniel Beck made changes -
            Link This issue is duplicated by JENKINS-36963 [ JENKINS-36963 ]
            aodo Alex Dover added a comment -

            Hi,
            Thanks for the fix!
            Any idea when this change is going to make it into the LTS release?


              People

              • Assignee:
                Unassigned
                Reporter:
                tklammer Thomas Klammer
              • Votes:
                2 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: