Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32389

ghprb failed to test code as it will look like after accepting pull request

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: ghprb-plugin
    • Labels:
      None
    • Environment:
      ghprb v1.29.6
      Jenkins v1.638
      matrix-project v1.6
      github-api v1.71
      git v2.4.0
      swarm v2.0
      swarm-client v2.0
    • Similar Issues:

      Description

      A recent PR:

      https://github.com/dCache/dcache/pull/2096

      triggered a corresponding build, as anticipated:

      https://ci.dcache.org/view/dCache%202.14/job/dCache-v2.14/88/

      This build detected no problems: the PR merged successfully, the corresponding code compiled cleanly and the downstream jobs (which deploy the build and run functional tests) all passed.

      However, when the pull-request (along with several others) was accepted, the build failed. Analysis of the problem showed that this pull-request alone was responsible for the problem and that, if the pull request was actually testing, the build could not have succeeded – the problem is also manually reproducible: creating a branch from the latest tagged release and manually cherry-picking the corresponding patch results in code that does not build.

      Therefore, for whatever reason, the ghprb plugin is not testing how the code will look after accepting the pull request.

        Attachments

          Activity

          paulmillar Paul Millar added a comment - - edited

          Any progress on this issue?

          We have had another, similar issue where the PR build failed to show any problem but the merged code was broken (fails to compile).

          Pull request:
          https://github.com/dCache/dcache/pull/2218

          Corresponding PR build:
          https://ci.dcache.org/job/dCache-v2.13/253/

          Broken build after merge:
          https://ci.dcache.org/job/dCache-v2.13/255/

          To me, if I cannot trust that the code being built (and tested) in the PR build is the code after accepting the PR then this plugin useless.

          paulmillar Paul Millar added a comment -

          Apologies,

          It turns out that the problem was due to misconfiguration: the Branch Specifier was not configured to be "${sha1}". This resulted in the wrong branch being built and problems not being caught.

          Sorry for the noise.

          Paul.


            People

            • Assignee:
              janinko Honza Brázdil
              Reporter:
              paulmillar Paul Millar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: