Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32441

SEVERE: Failed Loading plugin monitoring

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Incomplete
    • Component/s: monitoring-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 14.04
      Jenkins Core 1.625.3
    • Similar Issues:

      Description

      Unable to install/load Monitoring plugin 1.58.0

      SEVERE: Failed Loading plugin monitoring
      java.io.IOException: Failed to initialize
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:441)
      at hudson.PluginManager$2$1$1.run(PluginManager.java:371)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:905)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoSuchMethodError: net.bull.javamelody.Log4JAppender.setThreshold(Lorg/apache/log4j/Priority;)V
      at net.bull.javamelody.Log4JAppender.<init>(Log4JAppender.java:42)
      at net.bull.javamelody.Log4JAppender.<clinit>(Log4JAppender.java:34)
      at net.bull.javamelody.FilterContext.initLogs(FilterContext.java:281)
      at net.bull.javamelody.FilterContext.<init>(FilterContext.java:69)
      at net.bull.javamelody.MonitoringFilter.init(MonitoringFilter.java:112)
      at net.bull.javamelody.PluginMonitoringFilter.init(PluginMonitoringFilter.java:42)
      at org.jvnet.hudson.plugins.monitoring.HudsonMonitoringFilter.init(HudsonMonitoringFilter.java:52)
      at hudson.util.PluginServletFilter.addFilter(PluginServletFilter.java:108)
      at org.jvnet.hudson.plugins.monitoring.PluginImpl.start(PluginImpl.java:115)
      at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:449)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:438)

        Attachments

          Activity

          evernat evernat added a comment -

          It's very strange that log4j.jar file in the tomcat directory.
          Anyway, you probably have old versions of log4j-over-slf4j and of slf4j-api in your classpath.
          See https://github.com/javamelody/javamelody/issues/566

          To fix the issue, you should not have obsolete versions of log4j-over-slf4j and of slf4j-api.

          nelu Nelu Vasilica added a comment -

          Thank you for your answer. I have checked a few jenkins servers for obsolete log4j-over-slf4j and of slf4j-api but couldn't find any.
          I'll keep digging and let you know if I find a solution.

          evernat evernat added a comment -

          Nelu Vasilica Any news?

          evernat evernat added a comment -

          No response from the reporter, so closing as incomplete.

          evernat evernat added a comment -

          I think that I have found the cause of the issue: conflict between a log4.jar file in the classpath (for example, in tomcat/lib) AND log4j-over-slf4j-1.7.7.jar (which is old) in the jenkins war.

          So it would probably be fixed by either removing the log4j.jar file from the classpath OR by upgrading jenkins to 2.74 or later (because jenkins 2.74 upgrades log4j-over-slf4j to 1.7.25 as part of JENKINS-41631).


            People

            • Assignee:
              Unassigned
              Reporter:
              saml Samuel Lopez
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: