Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32910

Jelly file was not found after update

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: email-ext-plugin
    • Labels:
      None
    • Environment:
      Jenkins Version 1.642.1
      Email Extension Plugin Version 2.41
    • Similar Issues:

      Description

      Hallo,

      I use Jenkins Version 1.642.1. After an update by the Email Extension Plugin to Version 2.41, the plugin send me an mail with the following text:
      "Jelly file [html-with-health-and-console] was not found in $JENKINS_HOME/email-templates"

      In Version 2.40.5 is it successful and I don't change something. You can see the settings in the picture. The file exists (/var/lib/jenkins/email-templates/).

        Attachments

          Issue Links

            Activity

            ralfverstappen Ralf Verstappen added a comment -

            Checked the folder, but it does not exist.

            ralfverstappen Ralf Verstappen added a comment -

            I downloaded the source of this plugin and copied the content of the templates folder to the folder email-templates (created by hand).
            That solves the issue for us.

            kbrowder Kevin Browder added a comment -

            I suppose it's not that usefull to say "me to", but... I'm also seeing this. Downgrading to 2.40.5 fixes the issue. I'm on the latest jenkins and using the Jenkins docker release (I enabled updates so I wasn't stuck on the LTS).

            slide_o_mix Alex Earl added a comment -

            Ok, I'm pretty sure I know what the issue is. I should have a dot release today or tomorrow.

            slide_o_mix Alex Earl added a comment -

            Fixed class loader to previous behavior. Released as 2.41.2


              People

              • Assignee:
                slide_o_mix Alex Earl
                Reporter:
                alexander_niemeier Alexander Niemeier
              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: