Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33035

Editable Email Notification Upgrade Breaks Jenkins Boot Up

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: email-ext-plugin
    • Labels:
      None
    • Environment:
      Windows 2012. Jenkins 1.648. JRE 7u80
    • Similar Issues:

      Description

      When I update the email-ext-plugin to the 2.41 or 2.41.2 updates, it breaks Jenkins from even starting up with a java.lang.Error: java.lang.reflect.InvocationTargetException error that doesn't even allow the Jenkins UI to be functional. Have to remove the email-ext-plugin from the Plugins directory to get Jenkins back up again.

      Feb 19, 2016 7:57:26 AM hudson.util.BootFailure publish
      SEVERE: Failed to initialize Jenkins
      hudson.util.HudsonFailedToLoad: org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.WebAppMain$3.run(WebAppMain.java:237)
      Caused by: org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:269)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:44)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:935)
      at jenkins.model.Jenkins.<init>(Jenkins.java:816)
      at hudson.model.Hudson.<init>(Hudson.java:83)
      at hudson.model.Hudson.<init>(Hudson.java:79)
      at hudson.WebAppMain$3.run(WebAppMain.java:225)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110)
      at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:176)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$8.runTask(Jenkins.java:924)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:106)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at hudson.diagnosis.NullIdDescriptorMonitor.verifyId(NullIdDescriptorMonitor.java:89)
      ... 13 more

        Attachments

        1. error2.txt
          78 kB
        2. jenkins.err.log
          86 kB
        3. junit.png
          junit.png
          134 kB
        4. log.txt
          37 kB

          Issue Links

            Activity

            slide_o_mix Alex Earl added a comment -

            Your screenshot shows the plugin as disabled.

            nbl9999 Nathan Lindshield added a comment -

            I thought the same thing that it was disabled, but it's not clickable. If you try, then you get the below banner that it can't be disabled because of the dependencies.

            slide_o_mix Alex Earl added a comment -

            Check JENKINS_HOME to see if there is a .disabled file for the junit plugin.

            nbl9999 Nathan Lindshield added a comment -

            Alright, so somehow I managed to get the junit plugin disabled even though it is dependency for a large number of plugins. Tried uploading the junit 1.2 version and still showed as disabled. Had to go into the plugins directory and remove the disabled flag. Then the 1.2 version showed as an update. Updated it, restarted, then updated email-ext. No issues. Thanks for the fix and help.

            nbl9999 Nathan Lindshield added a comment -

            Fixed in 2.41.3!


              People

              • Assignee:
                slide_o_mix Alex Earl
                Reporter:
                nbl9999 Nathan Lindshield
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: