Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33308

Plugin Manager needs to consider implied plugin dependencies

    Details

    • Similar Issues:

      Description

      With 2.0, for the first time the default Jenkins distribution does not install bundled plugins. This includes all plugins detached from core, i.e. those that used to be a core feature, and are an implied dependency of plugins depending on an older version of core that still bundled them.

      Unfortunately, the Plugin Manager cannot handle this:

      Steps to reproduce

      1. Install Jenkins 2.0 without installing any plugins
      2. Go to the plugin manager and install Flexible Publish plugin

      Expected result

      Flexible Publish plugin and Matrix Project plugin, possibly others, get installed.

      Actual result

      Token Macro Plugin, Run Condition Plugin, Flexible Publish Plugin get installed. No Matrix Project Plugin

      Failed to load org.jenkins_ci.plugins.flexible_publish.FlexiblePublisher$FlexiblePublisherDescriptor
      java.lang.NoClassDefFoundError: hudson/matrix/MatrixAggregatable

      Notes

      Similarly, installed but disabled dependencies need to be re-enabled when a plugin requiring them gets installed. This is however not a regression in 2.0.

        Attachments

          Issue Links

            Activity

            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kzantow
            Path:
            core/src/main/java/hudson/ClassicPluginStrategy.java
            core/src/main/java/hudson/PluginManager.java
            http://jenkins-ci.org/commit/jenkins/5e8bb98ee071c67046fdd3a09d2021c272560207
            Log:
            JENKINS-33308 - automatically install previously bundled dependencies
            for plugins that depend on old Jenkins versions

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: kzantow Path: core/src/main/java/hudson/ClassicPluginStrategy.java core/src/main/java/hudson/PluginManager.java http://jenkins-ci.org/commit/jenkins/5e8bb98ee071c67046fdd3a09d2021c272560207 Log: JENKINS-33308 - automatically install previously bundled dependencies for plugins that depend on old Jenkins versions

              People

              • Assignee:
                kzantow Keith Zantow
                Reporter:
                danielbeck Daniel Beck
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: