Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: disk-usage-plugin
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Linux
    • Similar Issues:

      Description

      We updated Hudson from 1.292 to 1.293 under Linux, Tomcat 5.5.26, and JDK Sun
      1.6.0_12, 32 Bit-Version. We expirienced this exception after Tomcat restart:

      java.lang.NoSuchMethodError: hudson.model.PeriodicWork.(Ljava/lang/String;)V
      at hudson.plugins.disk_usage.DiskUsageThread.(DiskUsageThread.java:26)
      at hudson.plugins.disk_usage.DiskUsagePlugin.(DiskUsagePlugin.java:30)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at
      sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at
      sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      at java.lang.Class.newInstance0(Class.java:355)
      at java.lang.Class.newInstance(Class.java:308)
      at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:190)
      at hudson.PluginManager.(PluginManager.java:141)
      at hudson.model.Hudson.(Hudson.java:512)
      at hudson.WebAppMain$2.run(WebAppMain.java:190)

      No further user action in hudson possible. We tried several restarts, same result.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/plugins/disk-usage/src/main/java/hudson/plugins/disk_usage/DiskUsagePlugin.java
            trunk/hudson/plugins/disk-usage/src/main/java/hudson/plugins/disk_usage/DiskUsageProperty.java
            trunk/hudson/plugins/disk-usage/src/main/java/hudson/plugins/disk_usage/DiskUsageThread.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=16498
            Log:
            [FIXED JENKINS-3340]
            I'm sorry I broke the public contract in 1.293.
            I'll implement the proposed release process quickly, which would have caught this problem before 1.293 shipped.

            mindless Alan Harder added a comment -
                • Issue 3407 has been marked as a duplicate of this issue. ***
            bernd_clemenz bernd_clemenz added a comment -

            Intrestingly were all builds running perfectly, when executing the maven2 CLI directly in a console. No problems too, running the builds in a tomcat 6.0.24 servlet-container under Hudson. So the reason seems to bee located in Glassfish v2.1


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                bernd_clemenz bernd_clemenz
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: