Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All

      Description

      Build just hangs when it's almost complete. After I cancel the build (as it's
      stuck at:

      [INFO] Generating "Project Team" report.

      [INFO] Generating "Mailing Lists" report.

      [INFO] Generating "About" report.

      [INFO] Generating "Project Plugins" report.

      [INFO] Generating "Project Summary" report.

      [INFO] Generating "Dependencies" report.

      [HUDSON] Archiving site

      It reports the following error:

      [INFO] Unable to call getArtifactsDir. Invalid object ID 12

      [INFO] ------------------------------------------------------------------------

      [INFO] Trace

      java.lang.IllegalStateException: Unable to call getArtifactsDir. Invalid object
      ID 12

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:259)

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:246)

      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:206)

      at hudson.remoting.UserRequest.perform(UserRequest.java:92)

      at hudson.remoting.UserRequest.perform(UserRequest.java:46)

      at hudson.remoting.Request$2.run(Request.java:236)

      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)

      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)

      at java.util.concurrent.FutureTask.run(FutureTask.java:123)

      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)

      at java.lang.Thread.run(Thread.java:595)

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 317 minutes 26 seconds

      [INFO] Finished at: Tue Mar 24 12:49:30 MST 2009

      [INFO] Final Memory: 54M/132M

      This is from a Maven2 project. I'm not sure if it's Maven or Hudson which is
      causing the problem but since Hudson keeps it running for 317 minutes, something
      is wrong - build normally takes 30 min or less.

        Issue Links

          Activity

          gjeudy gjeudy added a comment -

          I also get this error and hudson never completed, the build was hung for 2 days.

          [HUDSON]
          Archiving /export/home/jboss/.hudson/jobs/RDM/workspace/dataplace/backoffice/rdm
          /rdm-hbm/pom.xml
          to /export/home/jboss/.hudson/jobs/RDM/modules/archinsurance.rdm$rdm-
          hbm/builds/2009-07-14_14-52-40/archive/archinsurance.rdm/rdm-hbm/1.5.6.0-
          SNAPSHOT/pom.xml
          [INFO] ------------------------------------------------------------------------
          [ERROR] FATAL ERROR
          [INFO] ------------------------------------------------------------------------
          [INFO] Unable to call getArtifactsDir. Invalid object ID 7
          [INFO] ------------------------------------------------------------------------
          [INFO] Trace
          java.lang.IllegalStateException: Unable to call getArtifactsDir. Invalid object
          ID 7
          at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform
          (RemoteInvocationHandler.java:259)
          at hudson.remoting.RemoteInvocationHandler$RPCRequest.call
          (RemoteInvocationHandler.java:246)
          at hudson.remoting.RemoteInvocationHandler$RPCRequest.call
          (RemoteInvocationHandler.java:206)
          at hudson.remoting.UserRequest.perform(UserRequest.java:92)
          at hudson.remoting.UserRequest.perform(UserRequest.java:46)
          at hudson.remoting.Request$2.run(Request.java:236)
          at java.util.concurrent.Executors$RunnableAdapter.call
          (Executors.java:417)
          at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
          at java.util.concurrent.FutureTask.run(FutureTask.java:123)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask
          (ThreadPoolExecutor.java:650)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run
          (ThreadPoolExecutor.java:675)
          at java.lang.Thread.run(Thread.java:595)
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 4182 minutes 9 seconds
          [INFO] Finished at: Fri Jul 17 12:34:55 EDT 2009
          [INFO] Final Memory: 36M/492M
          [INFO] ------------------------------------------------------------------------
          ERROR: Asynchronous execution failure
          java.util.concurrent.ExecutionException: java.lang.NullPointerException
          at hudson.remoting.Channel$1.adapt(Channel.java:514)
          at hudson.remoting.Channel$1.adapt(Channel.java:509)
          at hudson.remoting.FutureAdapter.get(FutureAdapter.java:55)
          at hudson.maven.MavenBuilder.call(MavenBuilder.java:173)
          at hudson.maven.MavenModuleSetBuild$Builder.call
          (MavenModuleSetBuild.java:577)
          at hudson.maven.MavenModuleSetBuild$Builder.call
          (MavenModuleSetBuild.java:523)
          at hudson.remoting.UserRequest.perform(UserRequest.java:92)
          at hudson.remoting.UserRequest.perform(UserRequest.java:46)
          at hudson.remoting.Request$2.run(Request.java:236)
          at java.util.concurrent.Executors$RunnableAdapter.call
          (Executors.java:417)
          at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
          at java.util.concurrent.FutureTask.run(FutureTask.java:123)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask
          (ThreadPoolExecutor.java:650)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run
          (ThreadPoolExecutor.java:675)
          at java.lang.Thread.run(Thread.java:595)
          Caused by: java.lang.NullPointerException
          at hudson.maven.MavenBuildProxy$Filter$AsyncInvoker.call
          (MavenBuildProxy.java:236)
          ... 9 more

          dvrzalik dvrzalik added a comment -

          Wrong component...

          breadfan_de breadfan_de added a comment -

          Hi,
          I also have a Invalid object ID exception:

          To create a single threaded execution queue for some project I use the
          recommended workaround using local loopback nodes. It works fine except for one
          multiproject build.

          The LoopbackSlaveNode is started via this:
          java -jar /opt/cc/samba-instances/hudson/var/locknoderoot/slave.jar -jnlpUrl
          "http://127.0.0.1:6666/computer/LoopbackSlaveConlayer/slave-agent.jnlp"

          Regards
          Chris

          The log:

          Parsing POMs
          ERROR: Processing failed due to a bug in the code. Please report this to
          users@hudson.dev.java.net
          java.lang.IllegalStateException: Unable to call accept. Invalid object ID 5
          at
          hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:268)
          at
          hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:255)
          at
          hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:215)
          at hudson.remoting.UserRequest.perform(UserRequest.java:104)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:236)
          at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
          at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
          at java.util.concurrent.FutureTask.run(FutureTask.java:138)
          at
          java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
          at
          java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
          at hudson.remoting.Engine$1$1.run(Engine.java:54)
          at java.lang.Thread.run(Thread.java:619)
          project=hudson.maven.MavenModuleSet@86c9a53[samba-conlayer]
          project.getModules()=[hudson.maven.MavenModule@885dbda[samba-conlayer/lms-samba:conlayer.app.util.war],
          hudson.maven.MavenModule@885db4e[samba-conlayer/lms-samba:conlayer.appserver],
          hudson.maven.MavenModule@87c76af[samba-conlayer/lms-samba:conlayer.batchexport.hooklets],
          hudson.maven.MavenModule@87c66b7[samba-conlayer/lms-samba:conlayer.batchexport.hooklets.config],
          hudson.maven.MavenModule@87c70c2[samba-conlayer/lms-samba:conlayer.batchexport.hooks],
          hudson.maven.MavenModule@8826e57[samba-conlayer/lms-samba:conlayer.batchimport.interfaces],
          hudson.maven.MavenModule@8826efc[samba-conlayer/lms-samba:conlayer.batchimport.server],
          hudson.maven.MavenModule@872aa23[samba-conlayer/lms-samba:conlayer.blac.ums.adapter],
          hudson.maven.MavenModule@885dc70[samba-conlayer/lms-samba:conlayer.bundle.deployment],
          hudson.maven.MavenModule@872b84c[samba-conlayer/lms-samba:conlayer.cdm.client],
          hudson.maven.MavenModule@8826f3e[samba-conlayer/lms-samba:conlayer.cdm.client.mock],
          hudson.maven.MavenModule@8826e38[samba-conlayer/lms-samba:conlayer.cdm.server],
          hudson.maven.MavenModule@8826f51[samba-conlayer/lms-samba:conlayer.clearing.jms.mock],
          hudson.maven.MavenModule@8827081[samba-conlayer/lms-samba:conlayer.commons],
          hudson.maven.MavenModule@885aaf4[samba-conlayer/lms-samba:conlayer.comp.services.hooklets],
          hudson.maven.MavenModule@81208d9[samba-conlayer/lms-samba:conlayer.comp.services.hooks],
          hudson.maven.MavenModule@83b7fc2[samba-conlayer/lms-samba:conlayer.core.comp.services.hooklets],
          hudson.maven.MavenModule@8291a05[samba-conlayer/lms-samba:conlayer.core.hooklets],
          hudson.maven.MavenModule@8217a74[samba-conlayer/lms-samba:conlayer.core.hooklets.preint],
          hudson.maven.MavenModule@8463d2d[samba-conlayer/lms-samba:conlayer.database],
          hudson.maven.MavenModule@81c1ef3[samba-conlayer/lms-samba:conlayer.database.setup],
          hudson.maven.MavenModule@88906e8[samba-conlayer/lms-samba:conlayer.ear],
          hudson.maven.MavenModule@82fe0c3[samba-conlayer/lms-samba:conlayer.hooklets],
          hudson.maven.MavenModule@879b24a[samba-conlayer/lms-samba:conlayer.hooks],
          hudson.maven.MavenModule@8779aa9[samba-conlayer/lms-samba:conlayer.info],
          hudson.maven.MavenModule@81e1c28[samba-conlayer/lms-samba:conlayer.install],
          hudson.maven.MavenModule@82e7db1[samba-conlayer/lms-samba:conlayer.integration.test],
          hudson.maven.MavenModule@879b18e[samba-conlayer/lms-samba:conlayer.job.interfaces],
          hudson.maven.MavenModule@873d3e7[samba-conlayer/lms-samba:conlayer.job.server],
          hudson.maven.MavenModule@8729f0c[samba-conlayer/lms-samba:conlayer.multiproject], hudson.maven.MavenModule@872a5d0[samba-conlayer/lms-samba:conlayer.multiproject.delegate],
          hudson.maven.MavenModule@884b868[samba-conlayer/lms-samba:conlayer.test],
          hudson.maven.MavenModule@88e9136[samba-conlayer/lms-samba:conlayer.test.conf],
          hudson.maven.MavenModule@879b1f8[samba-conlayer/lms-samba:conlayer.uniserv.hooklets],
          hudson.maven.MavenModule@88e9ebc[samba-conlayer/lms-samba:conlayer.uniserv.hooklets.config],
          hudson.maven.MavenModule@879b2b1[samba-conlayer/lms-samba:conlayer.uniserv.hooks],
          hudson.maven.MavenModule@88ea85d[samba-conlayer/lms-samba:conlayer.utils],
          hudson.maven.MavenModule@82a931b[samba-conlayer/lms-samba:conlayer.z6.interfaces.kdi],
          hudson.maven.MavenModule@85cb020[samba-conlayer/lms-samba:conlayer.z6.interfaces.kdi.client],
          hudson.maven.MavenModule@825ed8d[samba-conlayer/lms-samba:conlayer.z6.interfaces.kdi.impl]]
          project.getRootModule()=hudson.maven.MavenModule@872a5d0[samba-conlayer/lms-samba:conlayer.multiproject.delegate]
          FATAL: Unable to call accept. Invalid object ID 5
          java.lang.IllegalStateException: Unable to call accept. Invalid object ID 5
          at
          hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:268)
          at
          hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:255)
          at
          hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:215)
          at hudson.remoting.UserRequest.perform(UserRequest.java:104)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:236)
          at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
          at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
          at java.util.concurrent.FutureTask.run(FutureTask.java:138)
          at
          java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
          at
          java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
          at hudson.remoting.Engine$1$1.run(Engine.java:54)
          at java.lang.Thread.run(Thread.java:619)

          breadfan_de breadfan_de added a comment -

          Sorry forgot to mention the used hudson version: 1.323

          Regards
          Chris

          sanlaville sanlaville added a comment - - edited

          I also have the same problem of job frozen during archiving with huson 1.346 deployed on Jonas 4.8.6 on redhat

          I found no solution at the moment, and I have to kill the job with the following error:

          [HUDSON] Archiving .../.hudson/jobs/portal-deploy/workspace/portal/target/portal-1.0.0-SNAPSHOT.war to .../.hudson/jobs/portal-deploy/modules/...$portal/builds/2010-02-15_17-17-04/archive/.../portal/1.0.0-SNAPSHOT/portal-1.0.0-SNAPSHOT.war
          ERROR: Aborted Maven execution for InterruptedException
          java.lang.InterruptedException
          at java.lang.Object.wait(Native Method)
          at hudson.remoting.Request.call(Request.java:122)
          at hudson.remoting.Channel.call(Channel.java:551)
          at hudson.maven.ProcessCache$MavenProcess.call(ProcessCache.java:156)
          at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:480)
          at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:416)
          at hudson.model.Run.run(Run.java:1198)
          at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:304)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:122)
          Finished: ABORTED

          carlspring carlspring added a comment -

          Same problem, Linux, Hudson 1.363.

          hhuynh hhuynh added a comment -

          Could someone suggest a workaround? Some way to detect it programmatically so we can kill the stuck jobs?

          kohsuke Kohsuke Kawaguchi added a comment -

          To those who are experiencing this problem, please see http://wiki.jenkins-ci.org/display/JENKINS/Build+is+hanging and attach relevant information to this issue tracker so that we can fix the problem. Thank you!

          hhuynh hhuynh added a comment -

          I've attached some thread dump on that page.

          buckett Matthew Buckett added a comment -

          Attached is our thread dump (thread-dump-hang.txt).

          Last log line is:

          [HUDSON] Archiving /var/lib/hudson/jobs/oxford-sakai/workspace/gradebook/app/sakai-tool/target/sakai-gradebook-tool-2.6-SNAPSHOT.war to /var/lib/hudson/jobs/oxford-sakai/modules/org.sakaiproject$sakai-gradebook-tool/builds/2010-09-29_11-30-38/archive/org.sakaiproject/sakai-gradebook-tool/2.6-SNAPSHOT/sakai-gradebook-tool-2.6-SNAPSHOT.war

          The build is a large but it only seems to be hanging in a few places.

          buckett Matthew Buckett added a comment -

          We use the build timeout plugin to kill stuck jobs.

          http://wiki.jenkins-ci.org/display/JENKINS/Build-timeout+Plugin

          Although currently our build is hanging and even restart hudson doesn't seem to be allowing it to build correctly.

          buckett Matthew Buckett added a comment -

          After upgrading to 1.378 one of our builds was repeatedly failing. Downgrading to to 1.377 has given us a working hudson again.

          robertredd robertredd added a comment -

          Looks to be the same problem as 7572 which is now assigned to someone.

          mwebber mwebber added a comment -

          Closed, as this is a duplicate of JENKINS-7572, and the fix tracking is bing done there.


            People

            • Assignee:
              Unassigned
              Reporter:
              rfidler78 rfidler78
            • Votes:
              18 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: