Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33575

HTTP cannot redirect to HTTPS when using own Jetty rather than embedded Jetty

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: winstone-jetty
    • Labels:
      None
    • Environment:
      Jenkins 1.642.2
    • Similar Issues:

      Description

      Hi,

      I'm not sure if it's the right place to post this question.

      I can use own Jetty 9 to setup redirect all HTTP to HTTPs on Jenkins1.532.3 which do not have embeded Jetty. However, the HTTP failed to redirect to HTTPS when using latest LTS jenkins 1.642.2 with my own Jetty, not embedded Jetty.

      Does it need to do any further configuration for not use embeded jetty? My own Jetty 9 only configure following to redirect HTTP to HTTPS:

      <security-constraint>
      <web-resource-collection>
      <web-resource-name>Everything in the webapp</web-resource-name>
      <url-pattern>/*</url-pattern>
      </web-resource-collection>
      <user-data-constraint>
      <transport-guarantee>CONFIDENTIAL</transport-guarantee>
      </user-data-constraint>
      </security-constraint>

        Attachments

          Activity

          Hide
          danielbeck Daniel Beck added a comment -

          This is an issue tracker, not a support site. Looks more like a question for the jenkinsci-users mailing list.

          Show
          danielbeck Daniel Beck added a comment - This is an issue tracker, not a support site. Looks more like a question for the jenkinsci-users mailing list.

            People

            • Assignee:
              Unassigned
              Reporter:
              hai_lh hai li
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: