Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33594

Rebuilding broken in Jenkins ver. 1.653

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.653
      Delivery Pipeline Plugin ver. 0.9.8
    • Similar Issues:

      Description

      Steps to reproduce

      1. Create a pipeline with a rebuildable step
      2. Execute the step
      3. Trigger a rebuild of the step from the delivery pipeline view

      Expected result

      The new build's progress should be visible in the pipeline view.

      Actual result

      The rebuild button disappears and reappears after a couple of seconds. A new build is started for the step's job, but it's not visible in the delivery pipeline view.

      More information

      The issue seems to be caused by changes to CauseAction, as described in the comments of JENKINS-33467.

        Attachments

          Issue Links

            Activity

            noidi Timo Mihaljov created issue -
            noidi Timo Mihaljov made changes -
            Field Original Value New Value
            Priority Minor [ 4 ] Blocker [ 1 ]
            noidi Timo Mihaljov made changes -
            Link This issue is related to JENKINS-33467 [ JENKINS-33467 ]
            noidi Timo Mihaljov made changes -
            Summary Manual steps broken in Jenkins ver. 1.653 Rebuilding broken in Jenkins ver. 1.653
            Description h4. Steps to reproduce

            # Create a pipeline with a manually triggered step
            # Trigger the manual step

            h4. Expected result

            The build should be visible in the pipeline and the aggregated view.

            h4. Actual result

            A new build is created for the step's job, but it's not visible anywhere in the Delivery Pipeline view.

            h4. More information

            The issue seems to be caused by changes to CauseAction, as described in the comments of JENKINS-33467.
            h4. Steps to reproduce

            # Create a pipeline with a rebuildable step
            # Execute the step
            # Trigger a rebuild of the step from the delivery pipeline view

            h4. Expected result

            The new build's progress should be visible in the pipeline view.

            h4. Actual result

            The rebuild button disappears and reappears after a couple of seconds. A new build is started for the step's job, but it's not visible in the delivery pipeline view.

            h4. More information

            The issue seems to be caused by changes to CauseAction, as described in the comments of JENKINS-33467.
            noidi Timo Mihaljov added a comment -

            In case someone needs the fix before it's merged, I've uploaded a binary built from my branch: https://www.dropbox.com/s/t4aj3l3n6ea0qau/delivery-pipeline-plugin.hpi?dl=0

            jglick Jesse Glick added a comment -

            Seems like this was already fixed in 0.9.9.

            jglick Jesse Glick made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            pimyjenkins Rob Pimentel added a comment -

            Not sure if I need to reopen this or create a new issue. The symptoms are nearly identical, except I am not sure of the OP's meaning of "A new build is started for the step's job, but it's not visible in the delivery pipeline view." I also see that a new build is started (or at least it tries to start a new build), but there is no indication of a new build either in the pipeline view, or in the history of that job. The job is never triggered. I am running Jenkins 1.656. I first encountered issue 33591 (unable to trigger manual build in pipeline), because I was running version 1.5.1 of the plugin. I upgraded the plugin to 1.5.2, am able to manually trigger builds in the pipeline, but not able to retry builds in the pipeline. Thanks!

            pimyjenkins Rob Pimentel added a comment -

            Apologies. Just realized this bug was tied to Delivery Pipeline plugin. I also have that plugin installed, but my issue is tied to Build Pipeline plugin.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 169548 ] JNJira + In-Review [ 198631 ]

              People

              • Assignee:
                patbos Patrik Boström
                Reporter:
                noidi Timo Mihaljov
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: