Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33631

Git plugin - timeout after 10 minutes never sends credentials (401 observed on git repo)

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.652 installed on windows 2012, running as a domain account
      Git plugin 2.4.2
      Git client plugin 1.19.6
      Credentials plugin 1.25
      tfs 2015 update 1 Git Team Project
      git version 2.7.3.windows.1
    • Similar Issues:

      Description

      I verified the credentials file is created and has the correct information
      I tried 2 different credentials my user account and the jenkins domain account, both have read permissions in the repo

      If i take the same commands and put them in a "Execute batch command" it times out as well

      If i take the commands out of jenkins and run them in a command prompt they are successsful!

      Output from build
      Started by user ***** ******
      [EnvInject] - Loading node environment variables.
      Building in workspace C:\Program Files (x86)\Jenkins\jobs\WebAppTest\workspace
      [WS-CLEANUP] Deleting project workspace...
      [WS-CLEANUP] Done
      Cloning the remote Git repository
      Cloning repository https://<Git enabled tfs>/_git/Project
      > C:\Program Files\Git\bin\git.exe init C:\Program Files (x86)\Jenkins\jobs\WebAppTest\workspace # timeout=10
      Fetching upstream changes from https://<Git enabled tfs>/_git/Project
      > C:\Program Files\Git\bin\git.exe --version # timeout=10
      using .gitcredentials to set credentials
      > C:\Program Files\Git\bin\git.exe config --local credential.username <domain>\<username> # timeout=10
      > C:\Program Files\Git\bin\git.exe config --local credential.helper store --file=\"C:\Users\<username>\AppData\Local\Temp\git2738443241863674451.credentials\" # timeout=10
      > C:\Program Files\Git\bin\git.exe -c core.askpass=true fetch --tags --progress https://<Git enabled tfs>/_git/Project +refs/heads/:refs/remotes/origin/
      ERROR: Timeout after 10 minutes
      > C:\Program Files\Git\bin\git.exe config --local --remove-section credential # timeout=10
      ERROR: Error cloning remote repo 'origin'
      hudson.plugins.git.GitException: Command "C:\Program Files\Git\bin\git.exe -c core.askpass=true fetch --tags --progress https://<Git enabled tfs>/_git/Project +refs/heads/:refs/remotes/origin/" returned status code -1:
      stdout:
      stderr:
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:1719)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1463)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.access$300(CliGitAPIImpl.java:63)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$1.execute(CliGitAPIImpl.java:314)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$2.execute(CliGitAPIImpl.java:506)
      at hudson.plugins.git.GitSCM.retrieveChanges(GitSCM.java:1013)
      at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1053)
      at hudson.scm.SCM.checkout(SCM.java:485)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1269)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:607)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      at hudson.model.Run.execute(Run.java:1738)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      ERROR: null

      IIS Logs from TFS Server
      2016-03-17 15:57:39 192.168.**.888 GET /tfs/DefaultCollection/**/_git/project/info/refs service=git-upload-pack 443 - 888.888.*.** git/2.7.3.windows.1 - 401 2 5 0
      2016-03-17 16:01:22 192.168.888.888 GET /tfs/DefaultCollection/***/_git/project/info/refs service=git-upload-pack 443 - 192.168.*.** git/2.7.3.windows.1 - 401 2 5 0

      --no further traffic from jenkins.

        Attachments

          Issue Links

            Activity

            Hide
            markewaite Mark Waite added a comment -

            Please use the Jenkins users mailing list to request help from others in diagnosing credential related issues in your configuration. There are far more people who read the Jenkins users mailing list than read individual bug reports.

            If you are confident this is a bug in the git plugin, please provide precise steps to duplicate the bug (preferably using visualstudio.com or some other publicly accessible TFS server source). I regularly run automated and interactive tests which confirm that the plugin is able to clone from visualstudio.com.

            Show
            markewaite Mark Waite added a comment - Please use the Jenkins users mailing list to request help from others in diagnosing credential related issues in your configuration. There are far more people who read the Jenkins users mailing list than read individual bug reports. If you are confident this is a bug in the git plugin, please provide precise steps to duplicate the bug (preferably using visualstudio.com or some other publicly accessible TFS server source). I regularly run automated and interactive tests which confirm that the plugin is able to clone from visualstudio.com.

              People

              • Assignee:
                markewaite Mark Waite
                Reporter:
                chudson121 chris hudson
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: