Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33705

Security token not printed with proper line endings on Windows

    Details

    • Similar Issues:

      Description

      While testing on Windows, I noticed that the security token is hiding in my logs! (see the attached screenshot).

      I have a feeling that this is because the security token is being logged with Unix-specific line endings \n instead of Windows ones \r\n.

      Ideally we should be using our logging framework or some cross-platform abstraction to make this a bit easier

      If you can't find the security token in the screenshot, it's only one line starting with "*****"

        Attachments

          Issue Links

            Activity

            rtyler R. Tyler Croy created issue -
            rtyler R. Tyler Croy made changes -
            Field Original Value New Value
            Labels 2.0
            rtyler R. Tyler Croy made changes -
            Labels 2.0 2.0 testfest
            danielbeck Daniel Beck made changes -
            Assignee Daniel Beck [ danielbeck ]
            danielbeck Daniel Beck made changes -
            Remote Link This issue links to "PR 2150 (Web Link)" [ 14098 ]
            danielbeck Daniel Beck made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            scm_issue_link SCM/JIRA link daemon made changes -
            Status In Progress [ 3 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 169674 ] JNJira + In-Review [ 198657 ]

              People

              • Assignee:
                danielbeck Daniel Beck
                Reporter:
                rtyler R. Tyler Croy
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: