Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33828

Jenkins 2.0 plugins setup wizard - empty suggested

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Environment:
      docker image: jenkinsci/jenkins:2.0-beta-1
      browser: Chrome Version 49.0.2623.87 (64-bit), OS X El Capitan
    • Similar Issues:

      Description

      See screenshot, steps to reproduce:
      1. Go to 'Select plugins to install'
      2. Select 'None'
      3. Click 'Back'
      4. Go to 'Install suggested plugins'.

      Also 'Recommended' in 'Select plugins to install' is not restoring initial state if I uncheck plugins manually.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Daniel Beck
            Path:
            war/src/main/js/api/pluginManager.js
            war/src/main/js/pluginSetupWizardGui.js
            http://jenkins-ci.org/commit/jenkins/4d01c07db60dde404c0724938c4685d1e4d6ce76
            Log:
            Merge pull request #2190 from kzantow/JENKINS-33828-recommended-plugin-list-modifiable

            [FIX JENKINS-33828] - setup wizard was modifying the recommended plugin list

            Compare: https://github.com/jenkinsci/jenkins/compare/cbe9ea008af0...4d01c07db60d

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kzantow
            Path:
            war/src/main/js/api/pluginManager.js
            http://jenkins-ci.org/commit/jenkins/397ab3e2ca1d04cc14bd862d06dec45fcb9f85b3
            Log:
            JENKINS-33828 - setup wizard was modifying the recommended plugin list
            due to not returning a copy


              People

              • Assignee:
                kzantow Keith Zantow
                Reporter:
                mslusarczyk Michal Slusarczyk
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: