Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33950

Unbundled / implicit plugin dependencies may be installed multiple times

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      windows
      2.0-beta-1
    • Similar Issues:

      Description

      Run jenkins on windows (java -jar ...) in a clean jenkins home

      select a few plugins (pipeline - and something that depends on OWASP Markup Formatter)

      wait for the plugins to install
      create a new user

      Get told Jenkins is ready to use

      Rejoice

      Expected results

      Jenkins is ready to use with the plugins you installed

      Actual results

      A restart is required

      Go to http://localhost:8080/updateCenter/ and look at the status of plugins (may need to install another plugin)
      However you can see that

      • OWASP Markup Formatter Plugin antisamy-markup-formatter plugin is already installed. Jenkins needs to be restarted for the update to take effect
      • Pipeline workflow-aggregator plugin is already installed. Jenkins needs to be restarted for the update to take effect

      Both of these are incorrect.

      The wizard has requested the same version be installed multiple times.
      You can see this if you go to /pluginManager/installed and version 1.3 is installed - yet you can download to 1.3....

      So
      1) Jenkins should restart if it has installed plugins that require a restart to activate
      2) Jenkins should not try to install the same version of the plugin twice (infact it should not try to install any version of the same plugin twice - do it once and install the latest).

      For slow internet links the multiple isntalls will cause a longer than required setup time.

        Attachments

          Issue Links

            Activity

            teilo James Nord created issue -
            teilo James Nord made changes -
            Field Original Value New Value
            Priority Minor [ 4 ] Major [ 3 ]
            swashbuck1r Spike Washburn made changes -
            Labels 2.0 2.0-beta 2.0 2.0-beta community-bee
            kzantow Keith Zantow added a comment -

            James Nord I have not observed this behavior in the latest versions of the setup wizard, even when installing everything, it simply tells you "Jenkins is ready" and lets you continue to the app. Can we close this issue?

            teilo James Nord added a comment -

            let me re-test with beta-2

            teilo James Nord made changes -
            Description Run jenkins on windows (java -jar ...) in a clean jenkins home

            select a few plugins (pipeline - and something that depends on OWASP Markup Formatter)

            wait for the plugins to install
            create a new user

            Get told Jenkins is ready to use

            Rejoice

            h3. Expected results

            Jenkins is ready to use with the plugins you installed

            h3. Actual results

            A restart is required :-(

            Go to http://localhost:8080/updateCenter/ and look atht e status of plugins (may need to install another plugin)
            However you can see that

            * OWASP Markup Formatter Plugin antisamy-markup-formatter plugin is already installed. Jenkins needs to be restarted for the update to take effect
            * Pipeline workflow-aggregator plugin is already installed. Jenkins needs to be restarted for the update to take effect

            Both of these are incorrect.

            The wizard has requested the same version be installed multiple times.
            You can see this if you go to /pluginManager/installed and version 1.3 is installed - yet you can download to 1.3....

            So
            1) Jenkins should restart if it has installed plugins that require a restart to activate
            2) Jenkins should not try to install the same version of the plugin twice (infact it should not try to install any version of the same plugin twice - do it once and install the latest).

            For slow internet links the multiple isntalls will cause a longer than required setup time.

            Run jenkins on windows (java -jar ...) in a clean jenkins home

            select a few plugins (pipeline - and something that depends on OWASP Markup Formatter)

            wait for the plugins to install
            create a new user

            Get told Jenkins is ready to use

            Rejoice

            h3. Expected results

            Jenkins is ready to use with the plugins you installed

            h3. Actual results

            A restart is required :-(

            Go to http://localhost:8080/updateCenter/ and look at the status of plugins (may need to install another plugin)
            However you can see that

            * OWASP Markup Formatter Plugin antisamy-markup-formatter plugin is already installed. Jenkins needs to be restarted for the update to take effect
            * Pipeline workflow-aggregator plugin is already installed. Jenkins needs to be restarted for the update to take effect

            Both of these are incorrect.

            The wizard has requested the same version be installed multiple times.
            You can see this if you go to /pluginManager/installed and version 1.3 is installed - yet you can download to 1.3....

            So
            1) Jenkins should restart if it has installed plugins that require a restart to activate
            2) Jenkins should not try to install the same version of the plugin twice (infact it should not try to install any version of the same plugin twice - do it once and install the latest).

            For slow internet links the multiple isntalls will cause a longer than required setup time.

            swashbuck1r Spike Washburn added a comment -

            This seems like it's an existing behavior in the plugin manager (would happen even if you installed these manually via the plugin manager). This should be fixed in the context of the plugin manager core, it's not about the setup wizard.

            swashbuck1r Spike Washburn made changes -
            Labels 2.0 2.0-beta community-bee 2.0 2.0-beta
            teilo James Nord made changes -
            Attachment screenshot-1.png [ 32384 ]
            teilo James Nord added a comment - - edited

            Still an issue with beta-2

            If I skip the plugin wizard and go to the plugin manager and choose the same set of 19 plugins and choose install, then some are also requested to be installed twice and Jenkins requires a restart. So not a new defect - but I guess a side effect of removing all those bundled plugins and everything depends on them!

            kzantow Keith Zantow added a comment -

            Sorry, I completely misread the issue at first. Yes, this an issue with how the plugin manager handles the unbundled / implicit dependencies, unrelated to the setup wizard itself. I think it is a new defect caused by implicit handling of the previously bundled dependencies. I think it's a minor issue, but a valid one.

            kzantow Keith Zantow made changes -
            Summary 2.0 setup wizard fails to restart Jenkins when a restart is required Unbundled plugins / implicit plugin dependencies may be installed multiple times
            kzantow Keith Zantow made changes -
            Summary Unbundled plugins / implicit plugin dependencies may be installed multiple times Unbundled / implicit plugin dependencies may be installed multiple times
            kzantow Keith Zantow made changes -
            Assignee Keith Zantow [ kzantow ]
            kzantow Keith Zantow made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            danielbeck Daniel Beck added a comment -

            Fixed towards 2.1.

            danielbeck Daniel Beck added a comment -

            Fixed towards 2.1.

            I may have commented on the wrong issue here.

            kzantow Keith Zantow made changes -
            Remote Link This issue links to "PR 2258 (Web Link)" [ 14199 ]
            rtyler R. Tyler Croy made changes -
            Link This issue is related to JENKINS-34239 [ JENKINS-34239 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kzantow
            Path:
            core/src/main/java/hudson/model/UpdateCenter.java
            core/src/main/resources/hudson/model/UpdateCenter/DownloadJob/row.jelly
            http://jenkins-ci.org/commit/jenkins/bfeeec1d68f5e071a52085d61cc5de379dbe48e3
            Log:
            JENKINS-33950 - dependencies may be installed multiple times unnecessarily, resulting in erroneous restart required indicators

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kzantow
            Path:
            Jenkinsfile
            changelog.html
            cli/pom.xml
            cli/src/main/java/hudson/cli/CLI.java
            core/pom.xml
            core/src/main/java/hudson/ClassicPluginStrategy.java
            core/src/main/java/hudson/Functions.java
            core/src/main/java/hudson/PluginManager.java
            core/src/main/java/hudson/PluginWrapper.java
            core/src/main/java/hudson/Util.java
            core/src/main/java/hudson/model/Action.java
            core/src/main/java/hudson/model/ManagementLink.java
            core/src/main/java/hudson/model/TopLevelItemDescriptor.java
            core/src/main/java/hudson/model/UpdateCenter.java
            core/src/main/java/hudson/model/UpdateSite.java
            core/src/main/java/hudson/model/User.java
            core/src/main/java/hudson/model/View.java
            core/src/main/java/hudson/model/ViewDescriptor.java
            core/src/main/java/jenkins/ClassLoaderReflectionToolkit.java
            core/src/main/java/jenkins/model/Jenkins.java
            core/src/main/java/jenkins/model/RunIdMigrator.java
            core/src/main/resources/jenkins/install/pluginSetupWizard.properties
            core/src/main/resources/jenkins/management/Messages_lt.properties
            core/src/main/resources/jenkins/model/Messages_lt.properties
            core/src/main/resources/jenkins/slaves/systemInfo/Messages_lt.properties
            core/src/main/resources/jenkins/triggers/Messages_lt.properties
            core/src/test/java/jenkins/xml/XMLUtilsTest.java
            pom.xml
            test/pom.xml
            test/src/test/java/hudson/bugs/JnlpAccessWithSecuredHudsonTest.java
            test/src/test/java/hudson/model/ManagementLinkTest.java
            war/pom.xml
            war/src/main/js/pluginSetupWizardGui.js
            war/src/main/js/templates/pluginSelectionPanel.hbs
            war/src/main/js/templates/welcomePanel.hbs
            war/src/main/less/pluginSetupWizard.less
            http://jenkins-ci.org/commit/jenkins/2ada9b70464b19bf8f15edee86b683606b4d860f
            Log:
            Merge remote-tracking branch 'primary/master' into JENKINS-33950-multiple-dependency-install-fix

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Daniel Beck
            Path:
            core/src/main/java/hudson/model/UpdateCenter.java
            http://jenkins-ci.org/commit/jenkins/54270b33403801f8c831c9aec2f2f284661f8d25
            Log:
            Merge pull request #2258 from kzantow/JENKINS-33950-multiple-dependency-install-fix

            JENKINS-33950 dependencies may be installed multiple times

            Compare: https://github.com/jenkinsci/jenkins/compare/eee3dba3e651...54270b334038

            danielbeck Daniel Beck added a comment -

            Fixed towards 2.1.

            danielbeck Daniel Beck made changes -
            Status In Progress [ 3 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 169961 ] JNJira + In-Review [ 198746 ]

              People

              • Assignee:
                kzantow Keith Zantow
                Reporter:
                teilo James Nord
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: