Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: tasks-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Irregularly, when building any project, the hudson maven process ends with this
      nice stacktrace, causing the build to fail

      [HUDSON] Archiving
      /home/jboss/.hudson/jobs/parallelRun-model/workspace/parallelRun-model/target/parallelRun-model-1.2-SNAPSHOT.jar
      to
      /home/jboss/.hudson/jobs/parallelRun-model/modules/be.rvponp$parallelRun-model/builds/2009-03-31_16-43-26/archive/be.rvponp/parallelRun-model/1.2-SNAPSHOT/parallelRun-model-1.2-SNAPSHOT.jar
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] null
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.NullPointerException
      at
      hudson.plugins.tasks.TasksMavenResult.hasPreviousResult(TasksMavenResult.java:86)
      at hudson.plugins.tasks.util.BuildResult.loadNewWarnings(BuildResult.java:608)
      at hudson.plugins.tasks.util.BuildResult.getNewWarnings(BuildResult.java:594)
      at
      hudson.plugins.tasks.util.AbstractResultAction.updateBuildHealth(AbstractResultAction.java:339)
      at
      hudson.plugins.tasks.MavenTasksResultAction.update(MavenTasksResultAction.java:148)
      at hudson.maven.MavenModuleSetBuild.notifyModuleBuild(MavenModuleSetBuild.java:280)
      at hudson.maven.MavenBuild$ProxyImpl2.end(MavenBuild.java:386)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:263)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:246)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:206)
      at hudson.remoting.UserRequest.perform(UserRequest.java:92)
      at hudson.remoting.UserRequest.perform(UserRequest.java:46)
      at hudson.remoting.Request$2.run(Request.java:236)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 22 seconds
      [INFO] Finished at: Tue Mar 31 16:43:53 CEST 2009
      [INFO] Final Memory: 27M/49M
      [INFO] ------------------------------------------------------------------------
      Waiting for Hudson to finish collecting data
      channel stopped
      Finished: FAILURE

      This happens after the deploy step has been succesfully completed. The problem
      is not really reproduceable, as consecutive builds of the same project will not
      always lead to this NPE.

      The problem started happening with hudson v295 (or 294), the following plugins
      have been installed:

      Hudson plugin for "Polarion Webclient for SVN" 1.1
      Hudson Checkstyle Plug-in 2.7
      Hudson build timeout plugin 1.4
      Hudson Warnings Plug-in 2.5
      Hudson Task Scanner Plug-in 3.5
      Hudson Template Project plugin 1.0
      Deploy to container Plugin 1.3
      Hudson Dependency Analyzer Plugin 0.1
      Hudson JIRA plugin 1.16
      Green Balls 1.4 (disabled)
      URL SCM plugin 1.4
      Hudson FindBugs Plug-in 3.6
      Hudson disk-usage plugin 0.8
      Hudson Violations plugin 0.7.3
      Sidebar Link 1.1
      Hudson batch task plugin 1.6
      Hudson SCP publisher plugin 1.5.2
      Hudson Continuous Integration game 1.7
      Locale plugin 1.0
      Hudson PMD Plug-in 2.6
      Unnamed - org.jvnet.hudson.plugins:ftppublisher:hpi:0.9
      Hudson Duplicate Code Scanner Plug-in 1.6

      Personally, I have a feeling something is going wrong with executing a
      post-build action, but as the stacktrace seems generally-hudson-y, I'm not so sure.

        Attachments

          Issue Links

            Activity

            wheazel wheazel added a comment -

            Same problem running hudson 1.294, with following plugins:

            Hudson Checkstyle Plug-in 2.8
            Subversion Release plugin 0.1
            Hudson Task Scanner Plug-in 3.5
            Hudson Warnings Plug-in 2.6

            Also irregular.

            timconinx timconinx added a comment -

            after a plunge into the code: reassigning to the task scanner plugin.

            could you acknowledge that this bug is fixed for the 3.6 branch. It looks like
            rev 16779 will take care of this problem

            drulli Ulli Hafner added a comment -

            Already resolved.

                • This issue has been marked as a duplicate of 3400 ***

              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                timconinx timconinx
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: