Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3400

NPE in CheckStyleMavenResult.java:72

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: checkstyle-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      While building a maven2 project with "clean install site" goals, i get a NPE at
      the very end of the build which leads to a build failure.
      the 5 last builds were broken for various reasons including this one but the 6th
      was sucessfull.
      Deleting the 5 broken builds solves the problem

      Plugin version is 2.7
      end of console log was
      ...
      [TASKS] Scipping maven reporter: there is already a result available.
      [PMD] Successfully parsed file /jobs/project/workspace/target/pmd.xml of module
      project with 0 warnings.
      [CHECKSTYLE] Successfully parsed file
      /jobs/project/workspace/target/checkstyle-result.xml of module project with 4254
      warnings.
      [DRY] Successfully parsed file /jobs/project/workspace/target/cpd.xml of module
      project with 0 warnings.
      [HUDSON] Archiving site
      [HUDSON] Archiving /jobs/project/workspace/pom.xml to
      /jobs/project/modules/com.myco$project/builds/2009-03-31_20-38-32/archive/com.myco/project/0.0.1-SNAPSHOT/pom.xml
      [HUDSON] Archiving /jobs/project/workspace/target/project-0.0.1-SNAPSHOT.jar to
      /jobs/project/modules/com.myco$project/builds/2009-03-31_20-38-32/archive/com.myco/project/0.0.1-SNAPSHOT/project-0.0.1-SNAPSHOT.jar
      [HUDSON] Archiving /jobs/project/workspace/pom.xml to
      /jobs/project/modules/com.myco$project/builds/2009-03-31_20-38-32/archive/com.myco/project/0.0.1-SNAPSHOT/pom.xml
      [HUDSON] Archiving /jobs/project/workspace/target/project-0.0.1-SNAPSHOT.jar to
      /jobs/project/modules/com.myco$project/builds/2009-03-31_20-38-32/archive/com.myco/project/0.0.1-SNAPSHOT/project-0.0.1-SNAPSHOT.jar
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] null
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.NullPointerException
      at
      hudson.plugins.checkstyle.CheckStyleMavenResult.hasPreviousResult(CheckStyleMavenResult.java:72)
      at hudson.plugins.checkstyle.util.BuildResult.loadNewWarnings(BuildResult.java:608)
      at hudson.plugins.checkstyle.util.BuildResult.getNewWarnings(BuildResult.java:594)
      at
      hudson.plugins.checkstyle.util.AbstractResultAction.updateBuildHealth(AbstractResultAction.java:339)
      at
      hudson.plugins.checkstyle.MavenCheckStyleResultAction.update(MavenCheckStyleResultAction.java:102)
      at hudson.maven.MavenModuleSetBuild.notifyModuleBuild(MavenModuleSetBuild.java:280)
      at hudson.maven.MavenBuild$ProxyImpl2.end(MavenBuild.java:386)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:263)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:246)
      at
      hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:206)
      at hudson.remoting.UserRequest.perform(UserRequest.java:92)
      at hudson.remoting.UserRequest.perform(UserRequest.java:46)
      at hudson.remoting.Request$2.run(Request.java:236)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1 minute 40 seconds
      [INFO] Finished at: Tue Mar 31 20:40:16 CEST 2009
      [INFO] Final Memory: 72M/137M
      [INFO] ------------------------------------------------------------------------
      channel stopped
      Finished: FAILURE

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : drulli
            Path:
            trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/CheckStyleMavenResult.java
            trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/CheckStyleResult.java
            trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/util/BuildResult.java
            trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/util/ResultAction.java
            trunk/hudson/plugins/dry/src/main/java/hudson/plugins/dry/DryMavenResult.java
            trunk/hudson/plugins/dry/src/main/java/hudson/plugins/dry/DryResult.java
            trunk/hudson/plugins/dry/src/main/java/hudson/plugins/dry/util/BuildResult.java
            trunk/hudson/plugins/dry/src/main/java/hudson/plugins/dry/util/ResultAction.java
            trunk/hudson/plugins/findbugs/src/main/java/hudson/plugins/findbugs/FindBugsMavenResult.java
            trunk/hudson/plugins/findbugs/src/main/java/hudson/plugins/findbugs/FindBugsResult.java
            trunk/hudson/plugins/findbugs/src/main/java/hudson/plugins/findbugs/util/BuildResult.java
            trunk/hudson/plugins/findbugs/src/main/java/hudson/plugins/findbugs/util/ResultAction.java
            trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/PmdMavenResult.java
            trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/PmdResult.java
            trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/util/BuildResult.java
            trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/util/ResultAction.java
            trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/TasksMavenResult.java
            trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/TasksResult.java
            trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/util/BuildResult.java
            trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/util/ResultAction.java
            trunk/hudson/plugins/warnings/src/main/java/hudson/plugins/warnings/WarningsResult.java
            trunk/hudson/plugins/warnings/src/main/java/hudson/plugins/warnings/util/BuildResult.java
            trunk/hudson/plugins/warnings/src/main/java/hudson/plugins/warnings/util/ResultAction.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=16779
            Log:
            [FIXED JENKINS-3400] Pulled up previous result computation to BuildResult and added null check.

            drulli Ulli Hafner added a comment -
                • Issue 3399 has been marked as a duplicate of this issue. ***

              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                thomas_belot thomas_belot
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: