Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3403

maven snapshot deployment fails if no existing snapshot

    Details

    • Type: Bug
    • Status: In Progress
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      For a maven2 build, the post-build action "Deploy artifacts to Maven repository"
      fails if there is no snapshot already in the repository. Looking up the old
      snapshot number fails and the deployment bails out. The workaround is to make
      sure the repository is seeded with an initial snapshot, but this will need to be
      re-done whenever the version number of the artifact snapshot is changed.

        Attachments

          Activity

          Hide
          kohsuke Kohsuke Kawaguchi added a comment -

          If you have the console output from your failed build, please attach it.

          Show
          kohsuke Kohsuke Kawaguchi added a comment - If you have the console output from your failed build, please attach it.
          Hide
          troyronning troyronning added a comment -

          Created an attachment (id=1012)
          Build Error

          Show
          troyronning troyronning added a comment - Created an attachment (id=1012) Build Error

            People

            • Assignee:
              Unassigned
              Reporter:
              csurridge csurridge
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: