Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34103

jenkins reindex purges build queue

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Case:

      1. We have GIT hooks kicking off Jenkins jobs on PRs.
      2. There are N jobs in the queue.
      3. I need to modify a single config line in 100 jobs; therefore I do it via regex / cmd line.
      4. I goto admin panel in Jenkins and Reload Configuration from Disk

      Result:
      Job execution count looses some numbers. For instance: Build History goes 110, 111, 114.
      However, if I goto the page directly http://xxxxxxx:ppp/job/jobname/113/ I see the results of the job.... it executed successfully.

      In logs I see:

      
      Apr 07, 2016 10:12:38 AM SEVERE hudson.model.Executor run
      Unexpected executor death
      java.lang.IllegalStateException: /var/lib/jenkins/jobs/xxxxxx/builds/112 already existed; will not overwrite with xxxxxxxxx #112
          at hudson.model.RunMap.put(RunMap.java:188)
          at jenkins.model.lazy.LazyBuildMixIn.newBuild(LazyBuildMixIn.java:176)
          at hudson.model.AbstractProject.newBuild(AbstractProject.java:1019)
          at hudson.model.AbstractProject.createExecutable(AbstractProject.java:1210)
          at hudson.model.AbstractProject.createExecutable(AbstractProject.java:145)
          at hudson.model.Executor$1.call(Executor.java:364)
          at hudson.model.Executor$1.call(Executor.java:346)
          at hudson.model.Queue._withLock(Queue.java:1405)
          at hudson.model.Queue.withLock(Queue.java:1270)
          at hudson.model.Executor.run(Executor.java:346)

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Looks like a duplicate of JENKINS-27530.


              People

              • Assignee:
                Unassigned
                Reporter:
                greenscar James Sandlin
              • Votes:
                2 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: