Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3443

Skipping Cobertura coverage although build was successful

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: cobertura-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When using the cobertura plugin, no Cobertura coverage report were generated
      although the build was successful (but unstable).
      In the build configuration, the 'Consider only stable builds' checkbox is unchecked.
      The return code of the ant script is '0'

      BUILD SUCCESSFUL
      Total time: 84 minutes 48 seconds
      Recording test results
      Skipping Cobertura coverage report as build was not successful...
      [FINDBUGS] Collecting findbugs analysis files...
      [FINDBUGS] Successfully parsed file
      /usr/local/woeEnv/hudson/jobs/woe-entw/workspace/trunk/test/findbugs.xml of
      module test with 1883 warnings.
      [FINDBUGS] Found 1883 annotations (0 new, 123 high, 1760 normal, 0 low)
      [FINDBUGS] Don't changing build status, no threshold has been exceeded
      finished: UNSTABLE

        Attachments

          Issue Links

            Activity

            mindless Alan Harder added a comment -

            closing as duplicate of later report, because that one includes a patch.

                • This issue has been marked as a duplicate of 3475 ***

              People

              • Assignee:
                stephenconnolly Stephen Connolly
                Reporter:
                bjoern_konrad bjoern_konrad
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: