Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34524

Extended Choice Parameter Plug in in Jenkins 2.0 always show that there are scripts to approve

    Details

    • Similar Issues:

      Description

      It seeems that the Extended Choice Parameter Plug-In [tried version 0.64] and Jenkins ver. 2.0 don't work together.

      When I create a simple groovy script for the plugin and I try to launch the build it appears the message:

      "You have unapproved groovy scripts that need approval before they can be executed. Go to In-Process Script Approval page to approve your scripts."

      However in the approval page there are no scripts to be approved. See attached screenshot for the reference script I used.

      If the script is modified in the build configuration page, it is appearing correctly as a script to be approved. However approving it, will still display the message

      "You have unapproved groovy scripts that need approval before they can be executed. Go to In-Process Script Approval page to approve your scripts."

      This happened after the upgrade to Jenkins 2.0 from Jenkins ver. 1.656

        Attachments

        1. config-example.png
          config-example.png
          37 kB
        2. Selection_011.png
          Selection_011.png
          35 kB
        3. Selection_012.png
          Selection_012.png
          33 kB
        4. Selection_013.png
          Selection_013.png
          19 kB
        5. test_job_2.xml
          3 kB
        6. test_job.xml
          2 kB

          Activity

          Hide
          vimil vimil added a comment -

          I think I found the issue, the script-security plugin 1.19 is not compatible with the extended-choice-parameter plugin. You could try with 1.18 version of script-security plugin. in the meantime I'll work on a fix for this.

          Show
          vimil vimil added a comment - I think I found the issue, the script-security plugin 1.19 is not compatible with the extended-choice-parameter plugin. You could try with 1.18 version of script-security plugin. in the meantime I'll work on a fix for this.
          Hide
          vimil vimil added a comment -

          fixed in version 0.70

          Show
          vimil vimil added a comment - fixed in version 0.70
          Hide
          mpechner michael pechner added a comment -

          Same for me.
          Windows version 1.651.1, down graded to the 1.18 version and rebooted and remove the XML.
          Re-approved.

          Still has the message.

          Show
          mpechner michael pechner added a comment - Same for me. Windows version 1.651.1, down graded to the 1.18 version and rebooted and remove the XML. Re-approved. Still has the message.
          Hide
          mpechner michael pechner added a comment -

          down graded to 1.17 - all good.

          Show
          mpechner michael pechner added a comment - down graded to 1.17 - all good.
          Hide
          vimil vimil added a comment -

          Try 0.70 of extended choice parameter plugin. It has the fix for this issue

          Show
          vimil vimil added a comment - Try 0.70 of extended choice parameter plugin. It has the fix for this issue

            People

            • Assignee:
              vimil vimil
              Reporter:
              dawez Davide Z.
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: