Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3475

Cobertura plugin ignores "Consider only stable builds" setting

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cobertura-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      My expectation would be that:
      -when the "Consider only stable builds" checkbox is checked, Cobertura
      publishing would be skipped if the build had any status other than SUCCESS
      -when the "Consider only stable builds" checkbox is not checked, Cobertura
      publishing would be skipped if the build had any status other than SUCCESS or
      UNSTABLE
      -if the build was UNSTABLE when the Cobertura publisher was running, if there
      was a problem in the publishing, it would result in the build result being set
      to FAILURE

      What I'm currently seeing is that UNSTABLE builds are always skipped entirely,
      regardless of the setting of the "Consider only stable builds" checkbox.

      I'm planning on posting a candidate patch to address this defect shortly.

        Attachments

          Issue Links

            Activity

            davidmc24 davidmc24 added a comment -

            Created an attachment (id=660)
            Proposed patch

            mindless Alan Harder added a comment -
                • Issue 3155 has been marked as a duplicate of this issue. ***
            mindless Alan Harder added a comment -
                • Issue 3443 has been marked as a duplicate of this issue. ***
            gontard gontard added a comment -

            Hello Stephen,
            does this patch will be included in the next release?

            Kind regards

            davidmc24 davidmc24 added a comment -

            Assigning to myself

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : davidmc24
            Path:
            trunk/hudson/plugins/cobertura/src/main/java/hudson/plugins/cobertura/CoberturaBuildAction.java
            trunk/hudson/plugins/cobertura/src/main/java/hudson/plugins/cobertura/CoberturaPublisher.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=17954
            Log:
            [FIXED JENKINS-3475] - Apply patch to cobertura plugin to support including "unstable" builds in coverage reporting. Should be included in next release of the plugin (0.8.7).

            davidmc24 davidmc24 added a comment -

            Make myself the QA contact

            davidmc24 davidmc24 added a comment -

            Included in cobertura plugin version 0.8.7, which is now released.


              People

              • Assignee:
                davidmc24 davidmc24
                Reporter:
                davidmc24 davidmc24
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: