Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34864

MultiJob predefined parameters no longer passed to phase project

    Details

    • Similar Issues:

      Description

      In a MultiJob Project in the MultiJob Phase the Predefined parameters are no longer being passed to the phase project. In Jenkins version 1.651.1 or prior I defined env vars $PARENT_WORKSPACE and $UNIFIED_BUILD_NUMBER, using Inject Environment Variable.
      Then I passed these as Predefined Parameters to the Phase project. In the Phase project, the environment variables were undefined.
      After I upgraded to 1.651.2 this stopped working. Then I downgraded back to 1.651.1 and the functionality was restored.

        Attachments

          Issue Links

            Activity

            mcqkerry Kerry Hill created issue -
            mcsf M Chon made changes -
            Field Original Value New Value
            Component/s envinject-plugin [ 15893 ]
            mcsf M Chon made changes -
            Component/s core [ 15593 ]
            mcsf M Chon made changes -
            Labels jenkins plugin envinject jenkins multi-job plugin
            Attachment Screen Shot 2016-05-16 at 10.35.55 AM.png [ 32726 ]
            mcsf M Chon made changes -
            Attachment Screen Shot 2016-05-16 at 10.35.55 AM.png [ 32726 ]
            mcsf M Chon made changes -
            Attachment Screen Shot 2016-05-16 at 10.35.55 AM.png [ 32727 ]
            mcsf M Chon made changes -
            Labels envinject jenkins multi-job plugin envinject jenkins multi-job parameterized-trigger plugin
            Attachment Multijob Parameterized Trigger Predefined Parameters.PNG [ 32728 ]
            mcsf M Chon made changes -
            Attachment Screen Shot 2016-05-16 at 10.35.55 AM.png [ 32727 ]
            mcsf M Chon made changes -
            Description In a MultiJob Project in the MultiJob Phase the Predefined parameters are no longer being passed to the phase project. In Jenkins version 1.651.1 or prior I could pass the $WORKSPACE and $BUILD_NUMBER to the phase project, and after I upgraded to 1.651.2 this stopped working. Then I downgraded back to 1.651.1 and the functionality was restored. In a MultiJob Project in the MultiJob Phase the Predefined parameters are no longer being passed to the phase project. In Jenkins version 1.651.1 or prior I defined env vars $PARENT_WORKSPACE and $UNIFIED_BUILD_NUMBER, using Inject Environment Variable.
            Then I passed these as Predefined Parameters to the Phase project. In the Phase project, the environment variables were undefined.
            After I upgraded to 1.651.2 this stopped working. Then I downgraded back to 1.651.1 and the functionality was restored.
            langtonben Ben Langton added a comment -

            https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2016-05-11

            Jenkins > 2.2 is also affected. This new behavior is by design. I suspect a lot of people will disable it
            An option to hide parameters on the Build With Parameters screen would be useful. It is sometimes necessary to pass parameters from one job to another, but you don't necessarily want those parameters exposed when the job is run by itself.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 171063 ] JNJira + In-Review [ 184146 ]
            oleg_nenashev Oleg Nenashev made changes -
            Component/s core [ 15593 ]
            Component/s envinject-plugin [ 15893 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Closing as a duplicate of JENKINS-36124, which has been fixed in MultiJob 1.22

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-36124 [ JENKINS-36124 ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            arusubra ARULANANTH SUBRAMANIAM made changes -
            Description In a MultiJob Project in the MultiJob Phase the Predefined parameters are no longer being passed to the phase project. In Jenkins version 1.651.1 or prior I defined env vars $PARENT_WORKSPACE and $UNIFIED_BUILD_NUMBER, using Inject Environment Variable.
            Then I passed these as Predefined Parameters to the Phase project. In the Phase project, the environment variables were undefined.
            After I upgraded to 1.651.2 this stopped working. Then I downgraded back to 1.651.1 and the functionality was restored.
            In a MultiJob Project in the MultiJob Phase the Predefined parameters are no longer being passed to the phase project. In Jenkins version 1.651.1 or prior I defined env vars $PARENT_WORKSPACE and $UNIFIED_BUILD_NUMBER, using Inject Environment Variable.
             Then I passed these as Predefined Parameters to the Phase project. In the Phase project, the environment variables were undefined.
             After I upgraded to 1.651.2 this stopped working. Then I downgraded back to 1.651.1 and the functionality was restored.

              People

              • Assignee:
                Unassigned
                Reporter:
                mcqkerry Kerry Hill
              • Votes:
                7 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: