Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34868

java.lang.IllegalStateException on lanching job on remote slave

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 2.4
    • Similar Issues:

      Description

      Job starts on slave and fails directly at SCM checkout with this message :

      _Started by user Alexandre Aubert | AT Internet
      [EnvInject] - Loading node environment variables.
      Building remotely on Quality - BDXBLD005 (Quality) in workspace D:\Jenkins\workspace\Quality\Confirmation_tests_stag

      FATAL: Jenkins has not been started, or was already shut down
      java.lang.IllegalStateException: Jenkins has not been started, or was already shut down
      at jenkins.model.Jenkins.getInstance(Jenkins.java:766)
      at hudson.scm.SubversionSCM.descriptor(SubversionSCM.java:2544)
      at hudson.scm.SubversionSCM.createDefaultSVNOptions(SubversionSCM.java:1043)
      at hudson.scm.SubversionSCM.createClientManager(SubversionSCM.java:1033)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:965)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:945)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2772)
      at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:69)
      at java.lang.Thread.run(Unknown Source)
      at ......remote call to Quality - BDXBLD005(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
      at hudson.remoting.UserResponse.retrieve(UserRequest.java:252)
      at hudson.remoting.Channel.call(Channel.java:781)
      at hudson.FilePath.act(FilePath.java:1007)
      at hudson.FilePath.act(FilePath.java:996)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:894)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:830)
      at hudson.scm.SCM.checkout(SCM.java:485)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1269)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      at hudson.model.Run.execute(Run.java:1741)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Archiving artifacts

      Recording test results
      ERROR: Step ‘Publish JUnit test result report’ failed: Test reports were found but none of them are new. Did tests run?
      For example, D:\Jenkins\workspace\Quality\Confirmation_tests_stag\reports\TEST-Confirmation_tests.xml is 2 hr 11 min old

      Notifying upstream projects of job completion
      No emails were triggered.
      Finished: FAILURE_

      Reverting jenkins to 2.3 restores the right behavior : job run is ok.

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            It's a duplicate of JENKINS-34857


              People

              • Assignee:
                Unassigned
                Reporter:
                splashnenen Alexandre Aubert
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: