Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3488

Hudson Warning Plugin not finding files on remote machines

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: warnings-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Issue found testing with Warnings Plugin version 2.6. Hudson installed on one
      Linux platform and building on a remote Linux node. Using scons to build a
      project that is a mixture of C/C++ using the GNU compiler. The Warnings plugin
      does an excellent job of scanning the console output and identifying and
      reporting warnings and errors.

      Problem appears whil accessing Hudson and the Warnings Plugin, clicking on a
      link that is supposed to pull open the source and jump to the line that
      generated the warning/error. When link is clicked Hudson displays the
      following content:

      01 hudson.util.IOException2: remote file operation failed
      02 at hudson.FilePath.act(FilePath.java:548)
      03 at hudson.FilePath.copyTo(FilePath.java:987)
      04 at
      hudson.plugins.warnings.util.HealthAwarePublisher.copyFilesFromSlaveToMaster
      (HealthAwarePublisher.java:194)
      05 at hudson.plugins.warnings.util.HealthAwarePublisher.perform
      (HealthAwarePublisher.java:150)
      06 at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
      (AbstractBuild.java:372)
      07 at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep
      (AbstractBuild.java:360)
      08 at hudson.model.Build$RunnerImpl.post2(Build.java:183)
      09 at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:345)
      10 at hudson.model.Run.run(Run.java:943)
      11 at hudson.model.Build.run(Build.java:112)
      12 at hudson.model.ResourceController.execute(ResourceController.java:93)
      13 at hudson.model.Executor.run(Executor.java:119)
      14 Caused by: java.io.FileNotFoundException: rtre/utility/iicore/tst.c (No such
      file or directory)
      15 at java.io.FileInputStream.open(Native Method)
      16 at java.io.FileInputStream.<init>(FileInputStream.java:106)
      17 at hudson.FilePath$25.invoke(FilePath.java:991)
      18 at hudson.FilePath$25.invoke(FilePath.java:987)
      19 at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1517)
      20 at hudson.remoting.UserRequest.perform(UserRequest.java:69)
      21 at hudson.remoting.UserRequest.perform(UserRequest.java:23)
      22 at hudson.remoting.Request$2.run(Request.java:213)
      23 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      24 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      25 at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      26 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask
      (ThreadPoolExecutor.java:650)
      27 at java.util.concurrent.ThreadPoolExecutor$Worker.run
      (ThreadPoolExecutor.java:675)
      28 at java.lang.Thread.run(Thread.java:595)
      29 Can't copy file from slave to master: slave=rtre/utility/iicore/tst.c,
      master=/var/hudson/jobs/BriansTestInvigBuild/builds/2009-04-14_11-03-
      33/workspace-files/d31670b0.tmp

      The file /rtre/utility/iicore/tst.c is directly under the Hudson $WORKSPACE
      path. In my situation $WORKSPACE is '/var/hudson/workspace/TestBuild. and the
      absolute path to the billtst.c source
      is '/var/hudson/workspace/TestBuild/rtre/utility/iicore/tst.c'

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Integrated in Hudson Plug-ins (Compile) #39
            JENKINS-3488: Added test case that exposes the bug.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : drulli
            Path:
            trunk/hudson/plugins/analysis-core/src/main/java/hudson/plugins/analysis/core/ParserResult.java
            http://jenkins-ci.org/commit/33956
            Log:
            [FIXED JENKINS-3488] Use whole relative path to find matches in the workspace.

            drulli Ulli Hafner added a comment -

            Integrated in Hudson Plug-ins (Compile) #40
            [FIXED JENKINS-3488] Use whole relative path to find matches in the workspace.

            nlegrand Nicolas LE GRAND added a comment -

            Hi,

            I still have this problem with relative paths:

            see log here under :

            Content of file cs_wsserv_sscl_iedsec.c
            01 Copying the source file '/home/nlgrand/jenkins/workspace/Linux/workcopySVN_SB/se-security/services/platform/gnu/linux/services/../../../../src/cs_wsserv_sscl_iedsec.c' from the workspace to the build folder 'C:\Jenkins\jobs\Linux\builds\2013-09-13_11-11-20\workspace-files\4807484b.tmp' on the Jenkins master failed.
            02 Is the file '/home/nlgrand/jenkins/workspace/Linux/workcopySVN_SB/se-security/services/platform/gnu/linux/services/../../../../src/cs_wsserv_sscl_iedsec.c' a valid filename?
            03 If you are building on a slave: please check if the file is accessible under '$JENKINS_HOME/[job-name]//home/nlgrand/jenkins/workspace/Linux/workcopySVN_SB/se-security/services/platform/gnu/linux/services/../../../../src/cs_wsserv_sscl_iedsec.c'
            04 If you are building on the master: please check if the file is accessible under '$JENKINS_HOME/[job-name]/workspace//home/nlgrand/jenkins/workspace/Linux/workcopySVN_SB/se-security/services/platform/gnu/linux/services/../../../../src/cs_wsserv_sscl_iedsec.c'
            05 hudson.util.IOException2: remote file operation failed: /home/nlgrand/jenkins/workspace/Linux/workcopySVN_SB/se-security/services/src/cs_wsserv_sscl_iedsec.c at hudson.remoting.Channel@1f0c2de:Linux2
            06 at hudson.FilePath.act(FilePath.java:905)
            07 at hudson.FilePath.act(FilePath.java:882)
            08 at hudson.FilePath.copyTo(FilePath.java:1776)
            09 at hudson.plugins.analysis.core.HealthAwareRecorder.copyFilesWithAnnotationsToBuildFolder(HealthAwareRecorder.java:398)
            10 at hudson.plugins.warnings.WarningsPublisher.perform(WarningsPublisher.java:334)
            11 at hudson.plugins.analysis.core.HealthAwareRecorder.perform(HealthAwareRecorder.java:333)
            12 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
            13 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:804)
            14 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:776)
            15 at hudson.model.Build$BuildExecution.post2(Build.java:183)
            16 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:726)
            17 at hudson.model.Run.execute(Run.java:1628)
            18 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            19 at hudson.model.ResourceController.execute(ResourceController.java:88)
            20 at hudson.model.Executor.run(Executor.java:247)
            21 Caused by: java.io.FileNotFoundException: /home/nlgrand/jenkins/workspace/Linux/workcopySVN_SB/se-security/services/src/cs_wsserv_sscl_iedsec.c (No such file or directory)
            22 at java.io.FileInputStream.open(Native Method)
            23 at java.io.FileInputStream.<init>(FileInputStream.java:137)
            24 at hudson.FilePath$34.invoke(FilePath.java:1781)
            25 at hudson.FilePath$34.invoke(FilePath.java:1776)
            26 at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2417)
            27 at hudson.remoting.UserRequest.perform(UserRequest.java:118)
            28 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
            29 at hudson.remoting.Request$2.run(Request.java:326)
            30 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
            31 at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
            32 at java.util.concurrent.FutureTask.run(FutureTask.java:166)
            33 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
            34 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            35 at java.lang.Thread.run(Thread.java:679)

            I make some builds on Linux, and with Msbuild and Gcc on Windows.
            I have the problem on all those environments.

            drulli Ulli Hafner added a comment -

            Please create a new issue AND answer the questions from the log.


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                brianii brianii
              • Votes:
                8 Vote for this issue
                Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: