Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34954

Upgrade from LTS 1.651.1 to 1.651.2 broke functionality of parameterized trigger plugin

    Details

    • Similar Issues:

      Description

      After upgrading from 1.651.1 to 1.651.2, when accessing administration page, I found a warning about configuration versions.
      I found messages related to parameterized trigger and also promoted builds plugins, stating config version was 1.653.
      The option to change configuration compatibility only showed the same version 1.653.
      After applying it, however, the messages disappeared (though they appeared again later, perhaps because of executions of other tasks or new executions of the same ones).

      I have a commons task which is triggered via parameterized trigger plugin and receives from this plugin a file.
      The plugin si configured with some properties and a parameter factory to send one file to a concrete location and name of the common task.

      Before upgrading, everything worked fine.
      After upgrading, the task was triggered (therefore, the plugin found the file to send), but the file was never copied into the common-task workspace.

      Reverting to previous version, fixed the problem.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                huybrechts huybrechts
                Reporter:
                jafarre Juan Farré
              • Votes:
                3 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated: