Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34961

Build flow sections, created in older jenkins versions disappeared in Jenkins 2

    Details

    • Similar Issues:

      Description

      Build flow sections, created in older Jenkins versions disappeared in Jenkins 2.

      When rolling down the page you can see the build flow section, but when in focus it's disappeared.

      It's not reproduce with new build flow jobs been created in Jenkins 2.

        Attachments

          Issue Links

            Activity

            noamshochat noam shochat created issue -
            cheecheeo J C added a comment - - edited

            I'm also seeing this issue (at least the missing build flow sections) on:
            CentOS release 6.6
            build-flow-plugin 0.19
            Jenkins 2.5

            morshaked Mor Shaked made changes -
            Field Original Value New Value
            Rank Ranked higher
            morshaked Mor Shaked added a comment -

            Critical bug for us, we cant upgrade to 2.x till it will be fixed .

            morshaked Mor Shaked made changes -
            Rank Ranked higher
            ido_r Ido Reychan added a comment -

            I'm also seeing the problem

            kguelzau kguelzau added a comment -

            There is a request to

            <host>/job/<jobname>/descriptorByName/com.cloudbees.plugins.flow.BuildFlow/checkDsl?value=<value>
            

            which responses with <div/>.
            It seems this value is used when code area is completely viewable...

            kguelzau kguelzau made changes -
            Attachment DOM-Event Stacktrace.png [ 32913 ]
            kguelzau kguelzau added a comment - - edited

            Forget my last comment. This whole thing seems to be related to the new layout and "wrong" naming.
            Debugging the DOM-Event which changes the node to display:none, this seems to be triggerd by "ConfigRowGrouping.prototype.updateVisibility":

            To workaround: just temporarily check the checkbox "Flow run needs a workspace", edit the pipeline, uncheck and save.

            noamshochat noam shochat added a comment -

            this solution works for me. But as you said, only workaround.

            Thanks

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Suresh Kumar P
            Path:
            src/main/resources/com/cloudbees/plugins/flow/BuildFlow/configure-entries.jelly
            http://jenkins-ci.org/commit/build-flow-plugin/d3c3ca664aecfa969a6b220b6695256c8a1e770e
            Log:
            Build flow sections created in older Jenkins versions disappeared in Jenkins 2.x

            [FIXED JENKINS-34961]

            scm_issue_link SCM/JIRA link daemon made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            rodrigc Craig Rodrigues added a comment -

            Suresh Kumar provided a fix. Before I do a new release, can someone build the build-flow-plugin from source,
            and verify the fix? I will then do a release.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 171165 ] JNJira + In-Review [ 199048 ]
            rodrigc Craig Rodrigues made changes -
            Link This issue is duplicated by JENKINS-34936 [ JENKINS-34936 ]

              People

              • Assignee:
                rodrigc Craig Rodrigues
                Reporter:
                noamshochat noam shochat
              • Votes:
                15 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: