Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3497

Maven Generated Site Link no longer works in 1.299 (404)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:
      Show 5 results

      Description

      We just upgraded to 1.299 and now the Maven Generated Site Links return a 404.
      Tested on both Linux and Windows and fails on both.

        Attachments

          Issue Links

            Activity

            mdonohue mdonohue added a comment -

            What version of Hudson did you upgrade from? This sounds like a duplicate of
            issue 2411

            jochenhinrichsen jochenhinrichsen added a comment -

            Same problem over here.

            I upgraded from 1.296 to 1.299. This issue seems different from 2411, because
            appending project-info.html to the site URL does not help. The site entry point
            should be index.html anyway.

            The site links are the same for 1.296 and 1.299: Both look like

            http://$

            {server}

            :$

            {port}

            /job/$

            {job}

            /site

            ddlipsey ddlipsey added a comment -

            I was on 1.294.

            cj91 cj91 added a comment -

            Also experiencing the same problem. I don't think this is a duplicate issue...
            Also, the generated site report does exist in the site folder on the filesystem.
            Not sure why hudson isn't serving it up.

            mdonohue mdonohue added a comment -
                • Issue 2411 has been marked as a duplicate of this issue. ***
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/pom.xml
            trunk/hudson/main/test/src/test/java/hudson/maven/MavenProjectTest.java
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=18077
            Log:
            [FIXED JENKINS-3497] Maven generated site results in 404 because Stapler didn't recognize doDynamic(void)


              People

              • Assignee:
                Unassigned
                Reporter:
                ddlipsey ddlipsey
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: