Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35158

search box provides 404 and duplicates results for jobs in folders

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
    • Environment:
      Jenkins 1.642.2
      Folders Plugin 5.11
    • Similar Issues:

      Description

      When using folders (plugin), the search returns two results for a unique job: one with the job name and one with the folder plus the job name.
      The second one works fine, not the first one.

      When the searched phrase exactly matches a job name, you are redirected to that job instead of getting a list of results. As a consequence, searching for a job contained in a folder by its exact name will lead to a 404 page.

      For instance, in the attached screenshot, searching for "addons_nuxeo-drive-server-7.10" which is contained in the "7.10" folder:

      • hitting enter lead to 404
      • waiting for the suggested results returns an unusable "addons_nuxeo-drive-server-7.10" and a working "7.10 addons_nuxeo-drive-server-7.10".

      Note also that the both results work fine if the current page is the containing folder. From https://qa.nuxeo.org/jenkins/job/7.10/ , both the "relative path" "addons_nuxeo-drive-server-7.10" and the "folder relative or absolute path" "7.10 addons_nuxeo-drive-server-7.10" will work.

      It is not clear if "7.10 addons_nuxeo-drive-server-7.10" is an absolute or relative, full or partial path... What happens with a job contained in sub folders...?

        Attachments

          Issue Links

            Activity

            fbelzunc Félix Belzunce Arcos added a comment -

            I can re-produce sometimes the issue on your instance, but not on a fresh instance. Without a re-producible scenario on fresh instance I find hard to understand why the issue is happening and to fix it.

            As I said, on a fresh instance this issue is not re-producible using the same core version you are using and with latest Jenkins bits.

            mcrooney mcrooney added a comment - - edited

            Also seeing this on Jenkins 2.46.3 with CloudBees Folders 6.0.3. Issue is exactly as described; jobs in folders have two results, and the first one returns a 404, but the second is qualified with the folder before the name and works.

            davide_bolognini Davide Bolognini added a comment -

            Same problem with 2.73.1.

            danielbeck Daniel Beck added a comment -

            What kind of view is the search run in? IIRC the search functionality depends on the current view.

            oleg_nenashev Oleg Nenashev added a comment -

            The fix has been released in Jenkins 2.86, so it will be available in the next LTS release


              People

              • Assignee:
                Unassigned
                Reporter:
                jcarsique Julien Carsique
              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: