Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35176

"Tag this build" link repeated in Pipeline job with multiple svn step

    Details

    • Similar Issues:

      Description

      If you create a pipeline script like this

      node {
          svn 'https://SVN_URL/REPO_NAME/branches/branch1'
          svn 'https://SVN_URL/REPO_NAME/branches/branch2'
      }
      

      or

      node {
          checkout([
              $class: 'SubversionSCM',
              locations: [
                  [
                      credentialsId: '083ca939-470f-4bbd-9f32-30fc845fbb45',
                      depthOption: 'infinity',
                      ignoreExternalsOption: true,
                      local: './tmp', remote: 'https://SVN_URL/REPO_NAME/branches/branch2'
                  ]
              ],
              workspaceUpdater: [$class: 'CheckoutUpdater']
          ])
          checkout([
              $class: 'SubversionSCM',
              locations: [
                  [
                      credentialsId: '083ca939-470f-4bbd-9f32-30fc845fbb45',
                      depthOption: 'infinity',
                      ignoreExternalsOption: true,
                      local: '.', remote: 'https://SVN_URL/REPO_NAME/branches/branch2'
                  ]
              ],
              workspaceUpdater: [$class: 'CheckoutUpdater']
          ])
      }
      

      In the job build page appears the "Tag this build" link repeated.

      Both links are the same and shows the same information. This behaviour can not be reproduced with Freestyle because in Freestyle jobs you only can add one source code repository.

        Attachments

          Issue Links

            Activity

            dariver Darío Villadiego created issue -
            dariver Darío Villadiego made changes -
            Field Original Value New Value
            Labels pipe
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 171399 ] JNJira + In-Review [ 184296 ]
            abayer Andrew Bayer made changes -
            Component/s pipeline-general [ 21692 ]
            abayer Andrew Bayer made changes -
            Component/s workflow-plugin [ 18820 ]
            jglick Jesse Glick made changes -
            Component/s workflow-scm-step-plugin [ 21717 ]
            Component/s pipeline [ 21692 ]
            jglick Jesse Glick made changes -
            Link This issue is related to JENKINS-29840 [ JENKINS-29840 ]
            zswanson Zach Swanson added a comment -

            These might be dupes

            zswanson Zach Swanson made changes -
            Link This issue is related to JENKINS-38204 [ JENKINS-38204 ]
            jglick Jesse Glick added a comment -

            Probably a duplicate of JENKINS-38204.

            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-38204 [ JENKINS-38204 ]
            jglick Jesse Glick made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Assignee Jesse Glick [ jglick ]
            Resolution Duplicate [ 3 ]
            pascal_dulleck Pascal Dulleck made changes -
            Link This issue is related to JENKINS-39233 [ JENKINS-39233 ]
            r0ll1ngst0ne Michael Kostukov added a comment - - edited

            The issue is still present in Jenkins  2.150.3.

             

            When using scripted pipeline, each "checkout(changelog: false, scm: [$class: 'SubversionSCM'..." results in duplicated "Tag this build" links under the build:

             

             

            P.S. This is a separate issue from "Tag this build" appearing twice (which is also an unresolved bug). In addition to that, each svn checkout duplicates the duplicated links  In the image above, I have 4 checkouts - which result in 8 links (while there should be just 1!)

            r0ll1ngst0ne Michael Kostukov made changes -
            Resolution Duplicate [ 3 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            r0ll1ngst0ne Michael Kostukov made changes -
            Attachment image-2019-02-15-12-42-31-236.png [ 46032 ]
            jglick Jesse Glick made changes -
            Component/s workflow-scm-step-plugin [ 21717 ]
            bvandegriend Brian Vandegriend added a comment -

            Is there any workarounds to this issue?  The build results page ends up really cluttered due to the 10+ "Tag this build" links.  I would also like to see this resolved.

             

            andre4s_m Andreas Magnusson added a comment -

            Would it be possible to give us an option to just turn off the feature? We have never used the feature, so that would be an OK work-around for us.


              People

              • Assignee:
                Unassigned
                Reporter:
                dariver Darío Villadiego
              • Votes:
                12 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated: