Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35208

Unable to deploy the ear file using weblogic-deployer-plugin

    Details

    • Similar Issues:

      Description

      i'm getting the below error while running the job.And my build is getting failed

      [WeblogicDeploymentPlugin] - Pay attention of Jdk version

      {selected version is 1.8.0_60}

      compatibility with Weblogic Deployer API (see Oracle documentation).
      [WeblogicDeploymentPlugin] - The JDK /usr/java/jdk1.8.0_60/jre will be used.
      [WeblogicDeploymentPlugin] - Retrieving artifacts recorded [filtered resources on data-manager-ear(.*)\.ear]...
      [WeblogicDeploymentPlugin] - 143 files found under target
      [WeblogicDeploymentPlugin] - the following resource recorded /var/lib/jenkins/workspace/Build_Datamanager_BR2/datamanager-ear/target/data-manager-ear-0.0.2-SNAPSHOT.ear is eligible.
      [WeblogicDeploymentPlugin] - the following resource ['application.xml'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['application.xml'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['weblogic-application.xml'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['commons-beanutils-1.8.3.jar'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['sisu-guice-3.0.3-no_aop.jar'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['xalan-2.7.1.jar'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['poi-3.10-FINAL.jar'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['xml-resolver-1.2.jar'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['jaxb-impl-2.1.12.jar'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['wstx-asl-3.2.8.jar'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['geronimo-jaxws_2.1_spec-1.0.jar'] doesn't match data-manager-ear(.*)\.ear
      [WeblogicDeploymentPlugin] - the following resource ['ant-1.8.2.jar'] doesn't match data-manager-ear(.*)\.ear

        Attachments

          Activity

          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Fixed the component

          Show
          oleg_nenashev Oleg Nenashev added a comment - Fixed the component
          Hide
          raphc Raphael CHAUMIER added a comment -

          Hi Oleg Nenashev

          Did you fixed the issue ? Is the problem occurs since the new version of the plugin ?

          Regards

          Show
          raphc Raphael CHAUMIER added a comment - Hi Oleg Nenashev Did you fixed the issue ? Is the problem occurs since the new version of the plugin ? Regards
          Hide
          ayush15 Ayush T added a comment -

          HI

          No the issue is not fixed yet.But it is occurring after the new version.Earlier it was working fine.

          Show
          ayush15 Ayush T added a comment - HI No the issue is not fixed yet.But it is occurring after the new version.Earlier it was working fine.
          Hide
          raphc Raphael CHAUMIER added a comment - - edited

          Hi Ayush T,

          Can you attch the log of the deployment ?

          Regards

          Show
          raphc Raphael CHAUMIER added a comment - - edited Hi Ayush T , Can you attch the log of the deployment ? Regards

            People

            • Assignee:
              raphc Raphael CHAUMIER
              Reporter:
              ayush15 Ayush T
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: