Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3523

Hudson with about 150 defined jobs uses 40 min on boot time

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      I'm not sure if this could be categorized as a defect, but I'll try anyway.

      On my current project we're running Hudson (1.293) with no slaves defined. There
      are about 150 jobs configured. All of them are configured to poll the subversion
      repository every 10 min. The subversion repository is located on a different
      server than the Hudson instance.
      When Hudson is starting the cpu load on the server where subversion is running is
      increasing dramatically and it takes about 40 minutes to boot Hudson.
      Could this be a misconfiguration or is this normal behavior for Hudson running
      that amount of jobs?

        Attachments

          Issue Links

            Activity

            mdonohue mdonohue added a comment -

            Check out this thread:
            http://www.nabble.com/lazy-loading-of-test-results-into-memory-tp22710241p22728025.html

            There is a parallel startup feature that might help cut down the 40 minutes to
            something more reasonable. I don't think it will help with the SVN server load
            though.

            mariusbreivik mariusbreivik added a comment -

            Thanks for the reply.
            I'll try this out and post a comment on how it went.

            Marius

            mariusbreivik mariusbreivik added a comment -

            We're down to 23 minutes now. But I still think it's quite high.

            kohsuke Kohsuke Kawaguchi added a comment -

            Let's use issue #2487 to track this.

                • This issue has been marked as a duplicate of 2487 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                mariusbreivik mariusbreivik
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: