Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3553

Publishing Doxygen HTML results. dosnt work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: doxygen-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      Hi,

      When I compile the html files for doxygen as part of the compile script and tell
      the doxygen plugin to look for the html folder, nothing gets published.
      I get the following error:

      ----------------------
      ..
      ....

      Publishing Doxygen HTML results.

      FATAL: error
      hudson.util.IOException2: remote file operation failed
      at hudson.FilePath.act(FilePath.java:548)
      at hudson.plugins.doxygen.DoxygenArchiver.perform(DoxygenArchiver.java:160)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:372)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:360)
      at hudson.model.Build$RunnerImpl.cleanUp(Build.java:188)
      at hudson.model.Run.run(Run.java:938)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)

      Caused by: java.io.IOException: Unable to serialize
      hudson.FilePath$FileCallableWrapper@25d6d0bd
      at hudson.remoting.UserRequest.serialize(UserRequest.java:134)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:60)
      at hudson.remoting.Channel.call(Channel.java:480)
      at hudson.FilePath.act(FilePath.java:545)
      ... 8 more

      Caused by: java.io.NotSerializableException: java.io.PrintStream
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1173)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1526)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1491)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1409)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1167)
      at java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1526)
      at java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1491)
      at java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1409)
      at java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1167)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:343)
      at hudson.remoting.UserRequest._serialize(UserRequest.java:123)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:132)
      ... 11 more

      Finished: FAILURE

        Attachments

          Activity

          gbois Gregory Boissinot added a comment -

          Without any new errors, this issue is fixed.

          gbois Gregory Boissinot added a comment -

          I have corrected this bug last week and I have published a new plugin version: 0.3
          http://download.java.net/maven/2/org/jvnet/hudson/plugins/doxygen/0.3/

          So, it seems you still use doxygen plugin 0.2
          Could you update to the new doxygen plugin version?
          Thanks.


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              rajp rajp
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: