Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35565

multibranch project and git broken

    Details

    • Similar Issues:

      Description

      Hi,

      I try to create a pipeline project, but get always this error:

      {{
      Started
      Creating git repository in /var/lib/jenkins/caches/git-a2d04db821719ce9bac0f9be2f320f58
      Setting origin to https://mygithost/repo.git
      Fetching origin...

      FATAL: Failed to recompute children of MyTestProject
      hudson.plugins.git.GitException: org.eclipse.jgit.api.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
      at org.jenkinsci.plugins.gitclient.JGitAPIImpl.fetch(JGitAPIImpl.java:680)
      at jenkins.plugins.git.AbstractGitSCMSource.retrieve(AbstractGitSCMSource.java:174)
      at jenkins.scm.api.SCMSource.fetch(SCMSource.java:146)
      at jenkins.branch.MultiBranchProject.computeChildren(MultiBranchProject.java:294)
      at com.cloudbees.hudson.plugins.folder.computed.ComputedFolder.updateChildren(ComputedFolder.java:157)
      at com.cloudbees.hudson.plugins.folder.computed.FolderComputation.run(FolderComputation.java:122)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: org.eclipse.jgit.api.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
      at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:139)
      at org.jenkinsci.plugins.gitclient.JGitAPIImpl.fetch(JGitAPIImpl.java:678)
      ... 7 more
      Caused by: org.eclipse.jgit.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
      at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:524)
      at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:309)
      at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:136)
      at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
      at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1138)
      at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:130)
      ... 8 more
      Caused by: java.net.ConnectException: Connection refused mygithost
      at org.eclipse.jgit.util.HttpSupport.response(HttpSupport.java:175)
      at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:475)
      ... 13 more
      Finished: FAILURE
      }}

      the (jenkins-)user can clone the repo via "git clone https://mygithost/repo.git" on the command line.

      the ssl certifacte was added to the default truststore

      If I try to use plain http, it still creates the above error.

      Whats wrong in there?

        Attachments

          Issue Links

            Activity

            flow86 Florian Doersch created issue -
            flow86 Florian Doersch made changes -
            Field Original Value New Value
            Description Hi,

            I try to create a pipeline project, but get always this error:

            {{Started
            Creating git repository in /var/lib/jenkins/caches/git-a2d04db821719ce9bac0f9be2f320f58
            Setting origin to https://mygithost/repo.git
            Fetching origin...

            FATAL: Failed to recompute children of MyTestProject
            hudson.plugins.git.GitException: org.eclipse.jgit.api.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
            at org.jenkinsci.plugins.gitclient.JGitAPIImpl.fetch(JGitAPIImpl.java:680)
            at jenkins.plugins.git.AbstractGitSCMSource.retrieve(AbstractGitSCMSource.java:174)
            at jenkins.scm.api.SCMSource.fetch(SCMSource.java:146)
            at jenkins.branch.MultiBranchProject.computeChildren(MultiBranchProject.java:294)
            at com.cloudbees.hudson.plugins.folder.computed.ComputedFolder.updateChildren(ComputedFolder.java:157)
            at com.cloudbees.hudson.plugins.folder.computed.FolderComputation.run(FolderComputation.java:122)
            at hudson.model.ResourceController.execute(ResourceController.java:98)
            at hudson.model.Executor.run(Executor.java:410)
            Caused by: org.eclipse.jgit.api.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
            at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:139)
            at org.jenkinsci.plugins.gitclient.JGitAPIImpl.fetch(JGitAPIImpl.java:678)
            ... 7 more
            Caused by: org.eclipse.jgit.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
            at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:524)
            at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:309)
            at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:136)
            at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
            at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1138)
            at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:130)
            ... 8 more
            Caused by: java.net.ConnectException: Connection refused mygithost
            at org.eclipse.jgit.util.HttpSupport.response(HttpSupport.java:175)
            at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:475)
            ... 13 more
            Finished: FAILURE
            }}

            the (jenkins-)user can clone the repo via "git clone https://mygithost/repo.git" on the command line.

            the ssl certifacte was added to the default truststore

            If I try to use plain http, it still creates the above error.

            Whats wrong in there?
            Hi,

            I try to create a pipeline project, but get always this error:

            {{
            Started
            Creating git repository in /var/lib/jenkins/caches/git-a2d04db821719ce9bac0f9be2f320f58
            Setting origin to https://mygithost/repo.git
            Fetching origin...

            FATAL: Failed to recompute children of MyTestProject
            hudson.plugins.git.GitException: org.eclipse.jgit.api.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
            at org.jenkinsci.plugins.gitclient.JGitAPIImpl.fetch(JGitAPIImpl.java:680)
            at jenkins.plugins.git.AbstractGitSCMSource.retrieve(AbstractGitSCMSource.java:174)
            at jenkins.scm.api.SCMSource.fetch(SCMSource.java:146)
            at jenkins.branch.MultiBranchProject.computeChildren(MultiBranchProject.java:294)
            at com.cloudbees.hudson.plugins.folder.computed.ComputedFolder.updateChildren(ComputedFolder.java:157)
            at com.cloudbees.hudson.plugins.folder.computed.FolderComputation.run(FolderComputation.java:122)
            at hudson.model.ResourceController.execute(ResourceController.java:98)
            at hudson.model.Executor.run(Executor.java:410)
            Caused by: org.eclipse.jgit.api.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
            at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:139)
            at org.jenkinsci.plugins.gitclient.JGitAPIImpl.fetch(JGitAPIImpl.java:678)
            ... 7 more
            Caused by: org.eclipse.jgit.errors.TransportException: https://mygithost/repo.git: cannot open git-upload-pack
            at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:524)
            at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:309)
            at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:136)
            at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
            at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1138)
            at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:130)
            ... 8 more
            Caused by: java.net.ConnectException: Connection refused mygithost
            at org.eclipse.jgit.util.HttpSupport.response(HttpSupport.java:175)
            at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:475)
            ... 13 more
            Finished: FAILURE
            }}

            the (jenkins-)user can clone the repo via "git clone https://mygithost/repo.git" on the command line.

            the ssl certifacte was added to the default truststore

            If I try to use plain http, it still creates the above error.

            Whats wrong in there?
            markewaite Mark Waite added a comment -

            It may be that you've not enabled JGit on your Jenkins installation.

            From "Manage Jenkins", "Configure System" there is a button "Add Git". You may need to press that button and add JGit as a valid git implementation to your system.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 171875 ] JNJira + In-Review [ 184528 ]
            flow86 Florian Doersch added a comment -

            jgit is enabled, it seems its only a multi-branch-project bug: see https://issues.jenkins-ci.org/browse/JENKINS-35567

            flow86 Florian Doersch made changes -
            Component/s multi-branch-project-plugin [ 21127 ]
            jglick Jesse Glick added a comment -

            Wrong component.

            jglick Jesse Glick made changes -
            Component/s branch-api-plugin [ 18621 ]
            Component/s multi-branch-project-plugin [ 21127 ]
            Labels multibranch
            Assignee stephenconnolly [ stephenconnolly ]
            jglick Jesse Glick made changes -
            Link This issue is related to JENKINS-35567 [ JENKINS-35567 ]
            markewaite Mark Waite added a comment -

            Included in git plugin 2.6.0, released 2 Sep 2016.

            markewaite Mark Waite made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                flow86 Florian Doersch
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: