Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35689

OutOfMemoryError when clicking "Test Configuration"

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      Jenkins ver: 1.642
      Publish Over SSH plug-in: 1.14
    • Similar Issues:

      Description

      Hi, I get "java.lang.OutOfMemoryError: Java heap space" error when trying to setup a connection between jenkins server and a remote server. I've tried launching jenkins with "-Xmx4g" option, but this problem still occurs.

      This error occurred when I clicked on the "Test Configuration" button.

      This error occurs only when I check the box of "Use password authentication, or use a different key" and set my private key.

      I've attached my settings and the full stack trace.

        Attachments

          Activity

          slide_o_mix Alex Earl added a comment -

          I can't reproduce this issue, please reopen with additional details if it is still happening.

          slide_o_mix Alex Earl added a comment -

          Seems like your key may possibly be an invalid format for JSCh


            People

            • Assignee:
              slide_o_mix Alex Earl
              Reporter:
              lyenliang lyen liang
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: