Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35845

Internationalisation for Blue Ocean and JDL

    Details

    • Similar Issues:
    • Epic Link:
    • Sprint:
      pacific, atlantic, 1.0-b05/b-06, indian

      Description

      In Scope

      • All strings and formatting should be localisable
      • Short explanation on how we localise components and the app put in a README.md
      • Go through and extract all our current strings

      Notes

        Attachments

          Issue Links

            Activity

            jamesdumay James Dumay created issue -
            jamesdumay James Dumay made changes -
            Field Original Value New Value
            Epic Link UX-35 [ 24725 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint 1.0-m5 [ 36 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint 1.0-m5 [ 36 ] 1.0-m6 [ 16 ]
            jamesdumay James Dumay made changes -
            Status New [ 10200 ] To Do [ 10003 ]
            Workflow CloudBees Default Workflow [ 43095 ] Product Backlog April 2016 v2 [ 43301 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint 1.0-m6 [ 16 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-m8 [ 46 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Epic Link UX-35 [ 24725 ] UX-447 [ 28251 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-m8 [ 46 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            admin V R made changes -
            Project Import Tue Jun 14 12:50:41 JST 2016 [ 1465876241198 ]
            rtyler R. Tyler Croy made changes -
            Project Import Wed Jun 15 02:53:18 UTC 2016 [ 1465959198925 ]
            jamesdumay James Dumay made changes -
            Labels blueocean-imported
            jamesdumay James Dumay made changes -
            Project User Experience [ 10600 ] Jenkins [ 10172 ]
            Key UX-279 JENKINS-35845
            Workflow Product Backlog April 2016 V2 [ 172266 ] JNJira [ 172465 ]
            Status To Do [ 10003 ] Open [ 1 ]
            Component/s blueocean-plugin [ 21481 ]
            jamesdumay James Dumay made changes -
            Link This issue is duplicated by JENKINS-35904 [ JENKINS-35904 ]
            admin V R made changes -
            Priority Medium [ 3 ] Major [ 10000 ]
            admin V R made changes -
            Reporter James Dumay [ jdumay ] James Dumay [ jamesdumay ]
            admin V R made changes -
            Reporter James Dumay [ jdumay ] James Dumay [ jdumay ]
            jamesdumay James Dumay made changes -
            Assignee Keith Zantow [ kzantow ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-m11 [ 71 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint 1.0-m11 [ 71 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-m12 [ 76 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint 1.0-m12 [ 76 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint 1.0-m12 [ 76 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Priority Major [ 3 ] Minor [ 4 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint 1.0-m12 [ 76 ] 1.0-m13 [ 86 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 172465 ] JNJira + In-Review [ 184641 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-m13 [ 86 ] 1.0-m14 [ 96 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-beta-1 [ 96 ] 1.0-beta-2 [ 101 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Sprint 1.0-beta-4 [ 101 ] 1.0-beta-2 [ 111 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Priority Minor [ 4 ] Major [ 3 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Priority Major [ 3 ] Critical [ 2 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-b05/b-06 [ 111 ] 26-september, 1.0-b05/b-06 [ 101, 111 ]
            michaelneale Michael Neale made changes -
            Rank Ranked higher
            tscherler Thorsten Scherler made changes -
            Assignee Keith Zantow [ kzantow ] Thorsten Scherler [ tscherler ]
            tscherler Thorsten Scherler made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            michaelneale Michael Neale made changes -
            Description In Scope
            * All strings and formatting should be localisable
            * Short explanation on how we localise components and the app put in a README.md
            * Go through and extract all our current strings

            Notes
            * Looks like [react-intl|https://www.npmjs.com/package/react-intl] is the way things are done in React apps today. Here's a video from [React.js conf 2015|https://www.youtube.com/watch?v=Sla-DkvmIHY]
            In Scope
            * All strings and formatting should be localisable
            * Short explanation on how we localise components and the app put in a README.md
            * Go through and extract all our current strings
            * Clarify if routes (URIs) should be localised as well (they can be in some jenkins URIs but not sure if that is by accident or by design).

            Notes
            * Looks like [react-intl|https://www.npmjs.com/package/react-intl] is the way things are done in React apps today. Here's a video from [React.js conf 2015|https://www.youtube.com/watch?v=Sla-DkvmIHY]
            michaelneale Michael Neale made changes -
            Link This issue relates to JENKINS-36610 [ JENKINS-36610 ]
            michaelneale Michael Neale added a comment - - edited

            Keith Zantow - you were taking a look at this? Thorsten Scherler might want to check with keith before opening a PR (if work hasn't started).

            Also Keith - should route localisation be part of the scope of this? (do we want to do that? )
            EDIT: I think route i18n should be another ticket (as it is likely a hairy beast)

            michaelneale Michael Neale made changes -
            Description In Scope
            * All strings and formatting should be localisable
            * Short explanation on how we localise components and the app put in a README.md
            * Go through and extract all our current strings
            * Clarify if routes (URIs) should be localised as well (they can be in some jenkins URIs but not sure if that is by accident or by design).

            Notes
            * Looks like [react-intl|https://www.npmjs.com/package/react-intl] is the way things are done in React apps today. Here's a video from [React.js conf 2015|https://www.youtube.com/watch?v=Sla-DkvmIHY]
            In Scope
            * All strings and formatting should be localisable
            * Short explanation on how we localise components and the app put in a README.md
            * Go through and extract all our current strings

            Notes
            * Looks like [react-intl|https://www.npmjs.com/package/react-intl] is the way things are done in React apps today. Here's a video from [React.js conf 2015|https://www.youtube.com/watch?v=Sla-DkvmIHY]
            michaelneale Michael Neale made changes -
            Sprint pacific, 1.0-b05/b-06 [ 101, 111 ] pacific, atlantic, 1.0-b05/b-06 [ 101, 106, 111 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Thorsten Scherler
            Path:
            core/src/main/java/hudson/util/HttpResponses.java
            core/src/main/java/jenkins/util/ResourceBundleUtil.java
            test/src/test/java/jenkins/I18nTest.java
            http://jenkins-ci.org/commit/jenkins/ab16e52519260c0e9398f15256ed8061a4c00bf0
            Log:
            [FIX JENKINS-35845] Internationalisation for Blue Ocean and JDL (#2586)

            • Load i18n resource bundles from plugins if not found in jenkins core

            Signed-off-by: Thorsten Scherler <scherler@gmail.com>

            • Issue 404 response for missing i18n resource bundles

            Currently issues a 200 with an "error" response payload. This change still issues the error response payload, but also sets the HTTP response.

            Signed-off-by: Thorsten Scherler <scherler@gmail.com>

            • JENKINS-35845 add test for getting locale from plugin. fix comments from oleg.
            • eslint - formating changes and fix offences
            • eslint - formating changes and fix offences
            • JENKINS-35845 remove code concerning 404 response. Fix resourceBundle test by prevent NPE to happen
            scm_issue_link SCM/JIRA link daemon made changes -
            Status In Progress [ 3 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            oleg_nenashev Oleg Nenashev made changes -
            Component/s core [ 15593 ]
            oleg_nenashev Oleg Nenashev made changes -
            Labels blueocean-imported blueocean-imported lts-candidate
            oleg_nenashev Oleg Nenashev added a comment -

            The fix for the core is integrated towards 2.27.
            I consider the core fix as a bug, hence the patch is marked as lts-candidate

            michaelneale Michael Neale made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            michaelneale Michael Neale made changes -
            Status Reopened [ 4 ] In Progress [ 3 ]
            michaelneale Michael Neale added a comment -

            Not sure why this one was marked as closed when PR is still open...

            jamesdumay James Dumay made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06 [ 101, 106, 111 ] pacific, atlantic, 1.0-b05/b-06, indian [ 101, 106, 111, 126 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Michael Neale Because the core fix commit text contains the "FIX" text, hence Jenkins bot automatically closed it.
            You guys should not patch multiple components in a single task At least it complicates backporting of the fix to 2.19.3

            jamesdumay James Dumay added a comment -

            Thorsten Scherler before closing this ticket out please write some documentation and a cool blog post

            (I can help write the post if you need it)

            michaelneale Michael Neale added a comment -

            Oleg Nenashev is it ok to have this open or does it have to be closed to simplify the backporting? we can close this and open a ticket for the front end work side of things if that helps?

            oleg_nenashev Oleg Nenashev added a comment -

            Michael Neale it would be helpful

            michaelneale Michael Neale added a comment -

            Closing this as this tracks the core improvement

            michaelneale Michael Neale made changes -
            Status In Progress [ 3 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            michaelneale Michael Neale added a comment -

            Oleg Nenashev ok I made https://issues.jenkins-ci.org/browse/JENKINS-39225 to track the blue ocean side - you can take over this ticket if you like.

            tfennelly Tom FENNELLY made changes -
            Link This issue is blocking JENKINS-39345 [ JENKINS-39345 ]
            oleg_nenashev Oleg Nenashev made changes -
            Issue Type Story [ 10002 ] Bug [ 1 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Converted it to the bug, since Internalization support is an expected behavior for resource logic in Jenkins

            jglick Jesse Glick added a comment -

            This seems like a feature (a kind of API), not a bug. There is nothing broken in 2.19.3 without this IIUC—just some stuff Blue Ocean is not able to do.

            jglick Jesse Glick made changes -
            Link This issue is blocked by JENKINS-39604 [ JENKINS-39604 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Thorsten Scherler
            Path:
            core/src/main/java/hudson/util/HttpResponses.java
            core/src/main/java/jenkins/util/ResourceBundleUtil.java
            test/src/test/java/jenkins/I18nTest.java
            http://jenkins-ci.org/commit/jenkins/288a66dfabac0a31ce799cc3eaf285dc801cd668
            Log:
            [FIX JENKINS-35845] Internationalisation for Blue Ocean and JDL (#2586)

            • Load i18n resource bundles from plugins if not found in jenkins core

            Signed-off-by: Thorsten Scherler <scherler@gmail.com>

            • Issue 404 response for missing i18n resource bundles

            Currently issues a 200 with an "error" response payload. This change still issues the error response payload, but also sets the HTTP response.

            Signed-off-by: Thorsten Scherler <scherler@gmail.com>

            • JENKINS-35845 add test for getting locale from plugin. fix comments from oleg.
            • eslint - formating changes and fix offences
            • eslint - formating changes and fix offences
            • JENKINS-35845 remove code concerning 404 response. Fix resourceBundle test by prevent NPE to happen

            (cherry picked from commit ab16e52519260c0e9398f15256ed8061a4c00bf0)

            olivergondza Oliver Gondža made changes -
            Labels blueocean-imported lts-candidate 2.19.3-fixed blueocean-imported
            kzantow Keith Zantow made changes -
            Link This issue duplicates JENKINS-35270 [ JENKINS-35270 ]
            olivergondza Oliver Gondža made changes -
            Labels 2.19.3-fixed blueocean-imported 2.19.4-fixed blueocean-imported
            jbriden Jenn Briden made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              • Assignee:
                tscherler Thorsten Scherler
                Reporter:
                jamesdumay James Dumay
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: