Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3607

Matrix project loses upstream when config saved

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: matrix-project-plugin
    • Labels:
      None
    • Environment:
      Platform: Other, OS: Linux
    • Similar Issues:

      Description

      Attempting to set two multi-configuration projects in sequence is problematic.

      Steps to reproduce:

      Create two multi-configuration projects (e.g. "foo" and "bar"), and configure
      each one to build on two (or more) nodes. Go into bar's configuration and
      attempt to put foo upstream (i.e. put "foo" in "Build after other projects are
      built"). Save the configuration. Observe that the change did not take; bar has
      no upstream projects.

      Now, go into foo's configuration and put bar downstream (i.e. put "bar" in
      "Build other projects"). Save the configuration. (This part works.) Go into
      bar's configuration again, and note that "Build after other projects are built"
      correctly lists "foo". Don't change anything, just save the configuration.
      Observe that bar has no upstream projects again.

      Two symptoms, but they definitely appear to be the same issue. The first one is
      easier to work around, the second one is more of a pain. I first observed this
      with (I think) v1.289, but I can't say for sure that's when it appeared. It's
      still an issue as of v1.300.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mindless Alan Harder
                Reporter:
                acjohnso25 acjohnso25
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: