Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36215

Unable to deploy from a windows slave node

    Details

    • Similar Issues:

      Description

      We are trying to deploy a .war file into a weblogic server from Windows node using weblogic deployer plugin. Jenkins Master is on Linux while slave node 'VZK.WIN' is on Windows. We are getting below error while trying to do this. Can someone help us in resolving this issue.

      Started by user Natarajan, Bharath
      [EnvInject] - Loading node environment variables.
      Building remotely on CAO.EWDV.VZK in workspace D:\VZK.WIN\workspace\CAO.EWDV.Vzkauthoring.Vzk.Deploy_DEV
      [WeblogicDeploymentPlugin] - Pay attention of Jdk version

      {selected version is 1.8.0_25}

      compatibility with Weblogic Deployer API (see Oracle documentation).
      [WeblogicDeploymentPlugin] - The JDK /usr/java/jdk1.8.0_25/jre will be used.
      [WeblogicDeploymentPlugin] - Retrieving artifacts recorded [filtered resources on vzkauthoring.war]...
      [WeblogicDeploymentPlugin] - 2 files found under del
      [WeblogicDeploymentPlugin] - the following resource ['vzknowledge.war'] doesn't match vzkauthoring.war
      [WeblogicDeploymentPlugin] - the following resource recorded /apps/opt/jenkinsnfs/internal-vd/jnmisc/del/vzkauthoring.war is eligible.
      [WeblogicDeploymentPlugin] - Deploying the artifact on the following target : (name=DEV-DELETE-LATER-LINX) (host=abc.mycompany.com) (port=2001)
      [WeblogicDeploymentPlugin] - UNDEPLOYING ARTIFACT...
      $ /usr/java/jdk1.8.0_25/jre/bin/java -Xms256M -Xmx256M -cp /apps/opt/jenkinsnfs/internal-vd/jnmisc/weblogic/wlfullclient.jar weblogic.Deployer -debug -remote -verbose -noexit -name vzkauthoring -targets WLS_Cluster -adminurl t3://wlhost.mycompany.com:2001 -userconfigfile /apps/opt/jenkinsnfs/internal-vd/jnmisc/temp/myuserconfigfile.secure -userkeyfile /apps/opt/jenkinsnfs/internal-vd/jnmisc/temp/myuserkeyfile.secure -undeploy
      java.io.IOException: Cannot run program "/usr/java/jdk1.8.0_25/jre/bin/java": CreateProcess error=2, The system cannot find the file specified
      at java.lang.ProcessBuilder.start(Unknown Source)
      at hudson.Proc$LocalProc.<init>(Proc.java:244)
      at hudson.Proc$LocalProc.<init>(Proc.java:216)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:815)
      at hudson.Launcher$ProcStarter.start(Launcher.java:381)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1148)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1113)
      at hudson.remoting.UserRequest.perform(UserRequest.java:120)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:62)
      at java.lang.Thread.run(Unknown Source)
      at ......remote call to CAO.EWDV.VZK(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
      at hudson.remoting.UserResponse.retrieve(UserRequest.java:220)
      at hudson.remoting.Channel.call(Channel.java:781)
      at hudson.Launcher$RemoteLauncher.launch(Launcher.java:928)
      at hudson.Launcher$ProcStarter.start(Launcher.java:381)
      at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.undeploy(DeploymentTaskServiceImpl.java:274)
      at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.perform(DeploymentTaskServiceImpl.java:170)
      at org.jenkinsci.plugins.deploy.weblogic.WeblogicDeploymentPlugin.perform(WeblogicDeploymentPlugin.java:239)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
      at hudson.model.Run.execute(Run.java:1763)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(Unknown Source)
      at java.lang.ProcessImpl.start(Unknown Source)
      at java.lang.ProcessBuilder.start(Unknown Source)
      at hudson.Proc$LocalProc.<init>(Proc.java:244)
      at hudson.Proc$LocalProc.<init>(Proc.java:216)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:815)
      at hudson.Launcher$ProcStarter.start(Launcher.java:381)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1148)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:1113)
      at hudson.remoting.UserRequest.perform(UserRequest.java:120)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:326)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:62)
      at java.lang.Thread.run(Unknown Source)
      ERROR: [WeblogicDeploymentPlugin] - Failed to deploy.
      [INFO] ------------------------------------------------------------------------
      [INFO] DEPLOYMENT FAILURE
      [INFO] ------------------------------------------------------------------------
      Build step 'Deploy the artifact to any Weblogic environments' changed build result to FAILURE
      Started calculate disk usage of build
      Finished Calculation of disk usage of build in 0 seconds
      Started calculate disk usage of workspace
      Finished Calculation of disk usage of workspace in 0 seconds
      Notifying upstream projects of job completion
      Finished: FAILURE

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                raphc Raphael CHAUMIER
                Reporter:
                bharath_natarajan Bharath Natarajan
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: