Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3632

FATAL: <path to msbuild> doesn't exist

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: msbuild-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      In Hudson's configuration under MSBuild, I created an MSBuilder installation
      named ".NET 3.5" and set the path to
      "C:\WINDOWS\Microsoft.NET\Framework\v3.5\MSBuild.exe" (without the quotes).

      Then, in my job, I set msbuild to use ".NET 3.5", and then told the job to build.

      Here's the error at the end:

      At revision 562
      no revision recorded for
      http://repo.molecular.com/svn/tcwredesign/trunk/platform/tcw.com/visual%20studio/TCW
      in the previous build
      FATAL: C:\WINDOWS\Microsoft.NET\Framework\v3.5\MSBuild.exe doesn't exist
      Finished: FAILURE

      I tried surrounding the path with quotation marks in Hudson's configuration, but
      the error stayed the same.

      My hudson manager server runs on Linux, and the slave is Windows. This job is
      tied to that Windows slave, and I have checked many times to make sure that path
      is valid.

        Attachments

          Activity

          davidvl davidvl added a comment -

          Confirmed here as well. The path gets checked on the master instead of on the slave machine. Some workarounds:

          • install .NET 3.5 on master as well
          • use another builder, for example Ant or NAnt and exec MSBuild from it
          jsirex jsirex added a comment -

          I'm also using hudson in this scheme.
          An advice to candrews until this bug is closed:
          1. Delete from hudson (master) configuration any msbuild installations. Hudson will try to find it in current directory
          2. Goto slave node and add to %PATH% path to msbuild.exe binary file
          3. test it - start->run->cmd and type msbuild
          4. Restart slave service so it will be able to update paths
          5. Try

          Hope, this help you

          dotsev dotsev added a comment -

          Hello there,

          I think this bug is solved since MSBuild Plugin 1.4. Am I right?
          https://wiki.jenkins-ci.org/display/JENKINS/MSBuild+Plugin
          JENKINS-4121

          gbois Gregory Boissinot added a comment -

          Fixed from 1.4

          awenhu awen hu added a comment -

          I got same issue from version 1.24 / 1.23 / 1.5. Don't know why.


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              candrews candrews
            • Votes:
              16 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: