Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36356

Checkout error occurs randomly: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Not A Defect
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      subversion checkout randomly throws an exception on an external, which is located in the same repository as it is checking out.
      in my job i have provided credentials for all our repositories and for the svn-master. rerunning the build allways succeeds.

      hudson.util.IOException2: revision check failed on http://dualsrv-svn/svn/ganttplan/branches/v5.1_AutoSchedule/main/shared/general
      at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:208)
      at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:138)
      at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:725)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:860)
      at hudson.scm.SCM.checkout(SCM.java:495)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1269)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      at hudson.model.Run.execute(Run.java:1720)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
      svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:60)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:793)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:398)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:386)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:863)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:699)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:118)
      at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1049)
      at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(DAVRepository.java:189)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:118)
      at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:184)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:45)
      at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
      at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
      at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1235)
      at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
      at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
      at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:194)
      ... 12 more
      Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:723)
      ... 30 more

        Attachments

          Issue Links

            Activity

            ifernandezcalvo Ivan Fernandez Calvo added a comment -

            Did you test on latest version 2.10.5? the SVNKit library is the last stable version on that version

            jherb Joachim Herb added a comment -

            Why is this (and also all related bugs) closed? It is a real problem/bug, that every second build is broken due to a failed checkout. I know that there is a work around (somewhere described in one of the bugs), but this should not be the solution.

            ifernandezcalvo Ivan Fernandez Calvo added a comment -

            wrong credentials

            jenkins_user_12345 User Muster added a comment -

            We have the same problem. But we could not use the workaroud with the Additional Credentials because this is not availible with multipiple projects.

            When we manual click rebuild it worked.

            How could we help you to fix it?

             

            Jenkins version: 2.104

            Log:

            Using sole credentials jenkins/****** (svn user) in realm ?<http://192.168.1.23:80> Subversion Repository?
            Using sole credentials <none> in realm ?<http://192.168.1.23:80> Subversion Repository?
            ERROR: Checkout failed
            org.tmatesoft.svn.core.SVNCancelException: svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
                at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:728)
            Caused: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
                at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:66)
                at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:57)
                at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:798)
                at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:391)
                at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:379)
                at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:862)
                at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:698)
                at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:118)
                at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1049)
                at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(DAVRepository.java:189)
                at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:119)
                at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:195)
                at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:46)
                at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
                at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
                at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
                at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1235)
                at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
                at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
                at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
                at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:194)
            Caused: hudson.util.IOException2: revision check failed on http://192.168.1.23/svn/Projekte/test/trunk
                at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:208)
                at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:138)
                at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:756)
                at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:891)
                at org.jenkinsci.plugins.workflow.steps.scm.SCMStep.checkout(SCMStep.java:113)
                at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:143)
                at org.jenkinsci.plugins.workflow.multibranch.SCMBinder.create(SCMBinder.java:120)
                at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:271)
                at hudson.model.ResourceController.execute(ResourceController.java:97)
                at hudson.model.Executor.run(Executor.java:429)
            ERROR: Maximum checkout retry attempts reached, aborting
            Finished: FAILURE

             

            frahi Franz Hirschbeck added a comment -

            We have migrated our repository from one server to another, including the svn:externals. So the externals have been changed as well as the main path of the jenkins project's svn. I guess one could reproduce the behavior then, we had this problem with all of our projects.

            I also found a workaround: Using the "Additional Credentials" and entering ALL used credentials (including the one which usually should already be available with the "credentials" entry of the "Modules" section)

            frahi Franz Hirschbeck added a comment -

            Also happens on our build server. 

            • independent of fresh workspace or update
            • we have "Additional Credentials" defined in the project but they are used for an other external
            • errors happen randomly at about 10% of our builds, I don't see a pattern when this happens
            • there are automatic retries in the checkout, they are also failing
            • version:
              • jenkins: 2.56
              • subversion: 2.7.2
              • credentials: 2.1.13

            Log:

            org.tmatesoft.svn.core.SVNCancelException: svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:728)
            Caused: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:66)
            at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:57)
            at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:798)
            at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:391)
            at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:379)
            at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:862)
            at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:698)
            at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:118)
            at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1049)
            at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(DAVRepository.java:189)
            at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:119)
            at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:195)
            at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:46)
            at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
            at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
            at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
            at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1235)
            at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
            at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
            at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
            at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:194)
            Caused: hudson.util.IOException2: revision check failed on https://aaa.bbb.com/ccc/Env/CMake_Scripts/trunk
            at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:208)
            at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:138)
            at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:725)
            at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:860)
            at hudson.scm.SCM.checkout(SCM.java:495)
            at hudson.model.AbstractProject.checkout(AbstractProject.java:1280)
            at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
            at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
            at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
            at hudson.model.Run.execute(Run.java:1735)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:97)
            at hudson.model.Executor.run(Executor.java:405)
            Retrying after 10 seconds
            

             

             

             

            tapsa Tapio Reijonen added a comment -

            Same happen in our CI environment randomly.

            Jenkins 2.33
            SVN plugin 2.7.1

            No changes for https://xxx.com/svn/repos/xxx since the previous build
            hudson.util.IOException2: revision check failed on https://xxx.com/svn/repos/xxx
            at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:208)
            at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:138)
            at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:725)
            at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:860)
            at hudson.scm.SCM.checkout(SCM.java:495)
            at hudson.model.AbstractProject.checkout(AbstractProject.java:1278)
            at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
            at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
            at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
            at hudson.model.Run.execute(Run.java:1728)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:98)
            at hudson.model.Executor.run(Executor.java:404)
            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:66)
            at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:57)
            at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:798)
            at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:391)
            at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:379)
            at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:862)
            at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:698)
            at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:118)
            at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1049)
            at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(DAVRepository.java:189)
            at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:119)
            at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:195)
            at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:46)
            at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
            at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
            at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
            at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1235)
            at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
            at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
            at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
            at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:194)
            ... 12 more
            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:728)
            ... 30 more

            jherb Joachim Herb added a comment -

              People

              • Assignee:
                Unassigned
                Reporter:
                slindemann Steve Lindemann
              • Votes:
                10 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: