Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3643

Javancss doesn't run on a slave

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: javancss-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:

      Description

      I have the same error that violation plugin when i run javancss on a slave :

      java.io.IOException: Remote call failed
      at hudson.remoting.Channel.call(Channel.java:490)
      at hudson.FilePath.act(FilePath.java:625)
      at hudson.plugins.helpers.BuildProxy.doPerform(BuildProxy.java:71)
      at
      hudson.plugins.helpers.AbstractPublisherImpl.perform(AbstractPublisherImpl.java:30)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:372)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:360)
      at hudson.model.Build$RunnerImpl.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:345)
      at hudson.model.Run.run(Run.java:943)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)
      Caused by: java.lang.NoClassDefFoundError:
      hudson/maven/MavenBuildProxy$BuildCallable
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:465)
      at hudson.remoting.RemoteClassLoader.findClass(RemoteClassLoader.java:100)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:242)
      at hudson.remoting.ObjectInputStreamEx.resolveClass(ObjectInputStreamEx.java:50)
      at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1544)
      at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1466)
      at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1699)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1305)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:348)
      at hudson.remoting.UserRequest.perform(UserRequest.java:84)
      at hudson.remoting.UserRequest.perform(UserRequest.java:46)
      at hudson.remoting.Request$2.run(Request.java:236)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at hudson.remoting.Engine$1$1.run(Engine.java:54)
      at java.lang.Thread.run(Thread.java:595)
      FATAL: Unexpected exception
      java.lang.RuntimeException: Unexpected exception
      at hudson.plugins.helpers.BuildProxy.unwrapException(BuildProxy.java:118)
      at hudson.plugins.helpers.BuildProxy.doPerform(BuildProxy.java:80)
      at
      hudson.plugins.helpers.AbstractPublisherImpl.perform(AbstractPublisherImpl.java:30)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:372)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:360)
      at hudson.model.Build$RunnerImpl.post2(Build.java:183)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:345)
      at hudson.model.Run.run(Run.java:943)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)
      Caused by: java.io.IOException: Remote call failed
      at hudson.remoting.Channel.call(Channel.java:490)
      at hudson.FilePath.act(FilePath.java:625)
      at hudson.plugins.helpers.BuildProxy.doPerform(BuildProxy.java:71)
      ... 9 more
      Caused by: java.lang.NoClassDefFoundError:
      hudson/maven/MavenBuildProxy$BuildCallable
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:465)
      at hudson.remoting.RemoteClassLoader.findClass(RemoteClassLoader.java:100)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
      at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Class.java:242)
      at hudson.remoting.ObjectInputStreamEx.resolveClass(ObjectInputStreamEx.java:50)
      at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1544)
      at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1466)
      at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1699)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1305)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:348)
      at hudson.remoting.UserRequest.perform(UserRequest.java:84)
      at hudson.remoting.UserRequest.perform(UserRequest.java:46)
      at hudson.remoting.Request$2.run(Request.java:236)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
      at hudson.remoting.Engine$1$1.run(Engine.java:54)
      at java.lang.Thread.run(Thread.java:595)

        Attachments

          Issue Links

            Activity

            lauretamisier lauretamisier added a comment -

            Stephen,

            Do you know how to correct easly this problem ?
            In fact i have create a project with yur plugin for example so i have the same
            problem that you and i don't arrived to correct it.
            Can you help me to correct this error ??

            Thanks

            Laure

            felixdrueke Felix Drueke added a comment -

            This seems to be a duplicate of issue 3473 (yet in state "new")

                • This issue has been marked as a duplicate of 3473 ***

              People

              • Assignee:
                stephenconnolly Stephen Connolly
                Reporter:
                lauretamisier lauretamisier
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: