Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3653

Slave workspaces deleted too often

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:
      Show 5 results

      Description

      I have a job running on a slave. Once the job runs I can see the workspace in
      hudson. If I wait overnight and check again in the morning the workspace is gone
      with this error:
      Error: no workspace

      1. The project was renamed recently and no build was done under the new name.
      2. The slave this project has run on for the last time was removed.
      3. The workspace directory (null) is removed outside Hudson.

      Run a build to have Hudson create a workspace.

      Turning on more logging, I see the following:
      May 4, 2009 6:44:01 AM hudson.model.WorkspaceCleanupThread
      FINE: Directory
      /nfshomes/hudson/.hudson/jobs/B3_Full_Regression/workspace is not owned
      by any project

      May 4, 2009 6:44:01 AM hudson.model.WorkspaceCleanupThread
      FINE: Directory
      /nfshomes/hudson/.hudson/jobs/B3_Short_Regression/workspace is not owned
      by any project

      May 4, 2009 6:44:01 AM hudson.model.WorkspaceCleanupThread
      FINE: Directory /nfshomes/hudson/.hudson/jobs/PET-linux/workspace is
      only 4 days 20 hr old, so not deleting

      May 4, 2009 6:43:48 AM hudson.model.WorkspaceCleanupThread
      FINE: Directory /hudson/workspace/B3_Full_Regression is not owned by any
      project

      All of these workspaces are owned by a project and should not be deleted.

        Attachments

          Issue Links

            Activity

            mdonohue mdonohue added a comment -

            What version of Hudson are you using? Perhaps issue 3580 is related.

            jpschewe jpschewe added a comment -

            I'm using 1.301.

            No I don't believe issue 3580 is the same thing. No subversion checkout is run
            between the time that the workspace exists and the time that the workspace is
            deleted.

            mdonohue mdonohue added a comment -

            Perhaps this thread is relevant then:
            http://www.nabble.com/workspace-cleanup-thread-deleting-all-active-workspaces-tt23493027.html

            What security are you using?

            jpschewe jpschewe added a comment -

            I'm using project based security, so that might be it. Do we have a patch that
            could fix this? Can it be attached to the bug?

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/java/hudson/model/AsyncPeriodicWork.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=18068
            Log:
            [FIXED JENKINS-3653] Fixed in 1.305

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=18101
            Log:
            noting JENKINS-3653 fix in 1.305

            skaze skaze added a comment -

            I just upgraded from 828 to 304 and now my workspaces are deleting themselves?!

            I presume its ist to do with
            https://hudson.dev.java.net/issues/show_bug.cgi?id=3580 or
            https://hudson.dev.java.net/issues/show_bug.cgi?id=3653 but the fault is so
            severe that I may have to roll back.

            My projects are using scm polling, SVN update and project security. I don't want
            my 400M workspace of libraries deleted each time it checks for updates.

            When is the fix for this planned to be release?

            skaze skaze added a comment -

            I just upgraded from 828 to 304 and now my workspaces are deleting themselves?!

            I presume its ist to do with
            https://hudson.dev.java.net/issues/show_bug.cgi?id=3580 or
            https://hudson.dev.java.net/issues/show_bug.cgi?id=3653 but the fault is so
            severe that I may have to roll back.

            My projects are using scm polling, SVN update and project security. I don't want
            my 400M workspace of libraries deleted each time it checks for updates.

            When is the fix for this planned to be release?

            mdonohue mdonohue added a comment -
                • Issue 3705 has been marked as a duplicate of this issue. ***
            dannystaple Danny Staple added a comment - - edited

            This is being seen again both in hudson 1.393, and in jenkins 1.415.

            JENKINS-10615 shows exactly the same symptoms and looks to be a duplicate.

            danielbeck Daniel Beck added a comment -

            Jenkins 1.551 changed how the workspace cleanup thread works. So this can be assumed obsolete. Please just file a new issue if this problem occurs on Jenkins 1.551 or newer.

            Also, if this is a problem, you can always set -D hudson.model.WorkspaceCleanupThread.disabled=true to disable workspace cleanup.


              People

              • Assignee:
                Unassigned
                Reporter:
                jpschewe jpschewe
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: