Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36570

Implement pipeline compatibility

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The priority sorter plugin is not listed in the compatible plugin README.md. In addition, when using the "Run Exclusive" option, pipeline jobs get stuck in the queue. Unchecking the option leads to successful job migrations from the build queue to executors.

        Attachments

          Issue Links

            Activity

            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            COMPATIBILITY.md
            http://jenkins-ci.org/commit/pipeline-plugin/615a0b9b0c3ade0157da4cd8118398b608a1e679
            Log:
            JENKINS-36570 - Add PrioritySorter to the Pipeline Compatibility list

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: COMPATIBILITY.md http://jenkins-ci.org/commit/pipeline-plugin/615a0b9b0c3ade0157da4cd8118398b608a1e679 Log: JENKINS-36570 - Add PrioritySorter to the Pipeline Compatibility list
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            COMPATIBILITY.md
            http://jenkins-ci.org/commit/pipeline-plugin/db5cf31926d7e009cf30ed14a8e7325d384067e9
            Log:
            Merge pull request #428 from oleg-nenashev/PrioritySorter

            JENKINS-36570 - Add PrioritySorter to the Pipeline Compatibility list

            Compare: https://github.com/jenkinsci/pipeline-plugin/compare/74522f80f474...db5cf31926d7

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: COMPATIBILITY.md http://jenkins-ci.org/commit/pipeline-plugin/db5cf31926d7e009cf30ed14a8e7325d384067e9 Log: Merge pull request #428 from oleg-nenashev/PrioritySorter JENKINS-36570 - Add PrioritySorter to the Pipeline Compatibility list Compare: https://github.com/jenkinsci/pipeline-plugin/compare/74522f80f474...db5cf31926d7
            Hide
            dom Dominic Hargreaves added a comment -

            Oleg Nenashev I had a look at https://wiki.jenkins-ci.org/display/JENKINS/Priority+Sorter+Plugin and the only mention of pipeline is a change entry mentioning this ticket. But I can't see anywhere how one would allocated a node in a given job group, which I assume is how this would need to work, any examples at all of it being used in a pipeline script. So given your reference to existing documentation I suspect there's something I'm just not finding from a google search?

            Show
            dom Dominic Hargreaves added a comment - Oleg Nenashev I had a look at https://wiki.jenkins-ci.org/display/JENKINS/Priority+Sorter+Plugin  and the only mention of pipeline is a change entry mentioning this ticket. But I can't see anywhere how one would allocated a node in a given job group, which I assume is how this would need to work, any examples at all of it being used in a pipeline script. So given your reference to existing documentation I suspect there's something I'm just not finding from a google search?
            Hide
            dom Dominic Hargreaves added a comment -

            I was probably coming at this from the wrong direction. I can confirm that job groups/priority sorting works on a pipeline job as a whole and that is good enough for us at the moment.

            Show
            dom Dominic Hargreaves added a comment - I was probably coming at this from the wrong direction. I can confirm that job groups/priority sorting works on a pipeline job as a whole and that is good enough for us at the moment.
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Dominic Hargreaves There are some bits with Pipeline compatibility, e.g. JENKINS-44014

            But I would rather say the plugin is compatible though there is not enough documentation. If you could note your findings somehow, I could put them to Wiki/GitHub

             

            Show
            oleg_nenashev Oleg Nenashev added a comment - Dominic Hargreaves There are some bits with Pipeline compatibility, e.g. JENKINS-44014 But I would rather say the plugin is compatible though there is not enough documentation. If you could note your findings somehow, I could put them to Wiki/GitHub  

              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                jot1109 Jochen Hinrichsen
              • Votes:
                9 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: