Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36670

FATAL: hudson/tasks/Mailer$UserProperty java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Incomplete
    • Component/s: mailer-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver 1.638
      OS Centos
      mailer plugin 1.17
      Git plugin 2.2.9
      Git lab plugin 1.1.3
    • Similar Issues:

      Description

      I have several free style projects and i am seeing this error from last couple of days Randomly . Please find below the error trace . I did not come across any working solution anywhere . Please help !!

      Started by an SCM change
      Building on master in workspace /home/cmsbuild/Workspace/middletier
      > /usr/bin/git rev-parse --is-inside-work-tree # timeout=10
      Fetching changes from the remote Git repository
      > /usr/bin/git config remote.origin.url git@gitlab.ins.risk.regn.net:cmd/middletier.git # timeout=10
      Fetching upstream changes from git@gitlab.ins.risk.regn.net:cmd/middletier.git
      > /usr/bin/git --version # timeout=10
      using GIT_SSH to set credentials
      > /usr/bin/git -c core.askpass=true fetch --tags --progress git@gitlab.ins.risk.regn.net:cmd/middletier.git +refs/heads/:refs/remotes/origin/
      > /usr/bin/git rev-parse refs/remotes/origin/test_CI^

      {commit} # timeout=10
      > /usr/bin/git rev-parse refs/remotes/origin/origin/test_CI^{commit}

      # timeout=10
      Checking out Revision a2fa4a0cfae39d50d51d01d46190891f879b6d8a (refs/remotes/origin/test_CI)
      > /usr/bin/git config core.sparsecheckout # timeout=10
      > /usr/bin/git checkout -f a2fa4a0cfae39d50d51d01d46190891f879b6d8a
      > /usr/bin/git rev-list 2b4d0c33e20ba201fd0896b75223555f005dde98 # timeout=10
      FATAL: hudson/tasks/Mailer$UserProperty
      java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
      at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
      at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
      at hudson.model.AbstractBuild.access$600(AbstractBuild.java:104)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:619)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      at hudson.model.Run.execute(Run.java:1738)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      ... 13 more
      ERROR: Step ‘E-mail Notification’ aborted due to exception:
      java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
      at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
      at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
      at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:895)
      at hudson.tasks.MailSender.getChangeSet(MailSender.java:215)
      at hudson.tasks.MailSender.appendBuildUrl(MailSender.java:252)
      at hudson.tasks.MailSender.createFailureMail(MailSender.java:267)
      at hudson.tasks.MailSender.createMail(MailSender.java:180)
      at hudson.tasks.MailSender.run(MailSender.java:109)
      at hudson.tasks.Mailer.perform(Mailer.java:170)
      at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:76)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
      at hudson.model.Run.execute(Run.java:1763)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      ... 22 more
      FATAL: hudson/tasks/Mailer$UserProperty
      java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
      at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
      at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
      at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:895)
      at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:349)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:672)
      at hudson.model.Run.execute(Run.java:1763)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      ... 12 more
      Finished: FAILURE

        Attachments

          Activity

          madhukarreddy22 madhukar kasireddy created issue -
          slide_o_mix Alex Earl added a comment -

          Not sure why this was assigned to me.

          slide_o_mix Alex Earl made changes -
          Field Original Value New Value
          Assignee Alex Earl [ slide_o_mix ]
          madhukarreddy22 madhukar kasireddy added a comment -

          Alex Earl

          I saw a you responding a similar bug , so i thought you might have an idea . Is there a chance that you can assign it to the right person pls

          madhukarreddy22 madhukar kasireddy made changes -
          Description
          I have several free style projects and i am seeing this error from last couple of days *Randomly* . Please find below the error trace . I did not come across any working solution anywhere . Please help !!

          Started by an SCM change
          Building on master in workspace /home/cmsbuild/Workspace/middletier
           > /usr/bin/git rev-parse --is-inside-work-tree # timeout=10
          Fetching changes from the remote Git repository
           > /usr/bin/git config remote.origin.url git@gitlab.ins.risk.regn.net:cmd/middletier.git # timeout=10
          Fetching upstream changes from git@gitlab.ins.risk.regn.net:cmd/middletier.git
           > /usr/bin/git --version # timeout=10
          using GIT_SSH to set credentials
           > /usr/bin/git -c core.askpass=true fetch --tags --progress git@gitlab.ins.risk.regn.net:cmd/middletier.git +refs/heads/*:refs/remotes/origin/*
           > /usr/bin/git rev-parse refs/remotes/origin/test_CI^{commit} # timeout=10
           > /usr/bin/git rev-parse refs/remotes/origin/origin/test_CI^{commit} # timeout=10
          Checking out Revision a2fa4a0cfae39d50d51d01d46190891f879b6d8a (refs/remotes/origin/test_CI)
           > /usr/bin/git config core.sparsecheckout # timeout=10
           > /usr/bin/git checkout -f a2fa4a0cfae39d50d51d01d46190891f879b6d8a
           > /usr/bin/git rev-list 2b4d0c33e20ba201fd0896b75223555f005dde98 # timeout=10
          FATAL: hudson/tasks/Mailer$UserProperty
          java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
          at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
          at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
          at hudson.model.AbstractBuild.access$600(AbstractBuild.java:104)
          at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:619)
          at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
          at hudson.model.Run.execute(Run.java:1738)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:410)
          Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
          at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
          at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
          at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
          ... 13 more
          ERROR: Step ‘E-mail Notification’ aborted due to exception:
          java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
          at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
          at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
          at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:895)
          at hudson.tasks.MailSender.getChangeSet(MailSender.java:215)
          at hudson.tasks.MailSender.appendBuildUrl(MailSender.java:252)
          at hudson.tasks.MailSender.createFailureMail(MailSender.java:267)
          at hudson.tasks.MailSender.createMail(MailSender.java:180)
          at hudson.tasks.MailSender.run(MailSender.java:109)
          at hudson.tasks.Mailer.perform(Mailer.java:170)
          at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:76)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
          at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
          at hudson.model.Build$BuildExecution.post2(Build.java:185)
          at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
          at hudson.model.Run.execute(Run.java:1763)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:410)
          Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
          at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
          at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
          at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
          ... 22 more
          FATAL: hudson/tasks/Mailer$UserProperty
          java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
          at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
          at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
          at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:895)
          at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:349)
          at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:672)
          at hudson.model.Run.execute(Run.java:1763)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:410)
          Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
          at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
          at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
          at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
          ... 12 more
          Finished: FAILURE
          I have several free style projects and i am seeing this error from last couple of days *Randomly* . Please find below the error trace . I did not come across any working solution anywhere . Please help !!

          Started by an SCM change
          Building on master in workspace /home/cmsbuild/Workspace/middletier
           > /usr/bin/git rev-parse --is-inside-work-tree # timeout=10
          Fetching changes from the remote Git repository
           > /usr/bin/git config remote.origin.url git@gitlab.ins.risk.regn.net:cmd/middletier.git # timeout=10
          Fetching upstream changes from git@gitlab.ins.risk.regn.net:cmd/middletier.git
           > /usr/bin/git --version # timeout=10
          using GIT_SSH to set credentials
           > /usr/bin/git -c core.askpass=true fetch --tags --progress git@gitlab.ins.risk.regn.net:cmd/middletier.git +refs/heads/*:refs/remotes/origin/*
           > /usr/bin/git rev-parse refs/remotes/origin/test_CI^{commit} # timeout=10
           > /usr/bin/git rev-parse refs/remotes/origin/origin/test_CI^{commit} # timeout=10
          Checking out Revision a2fa4a0cfae39d50d51d01d46190891f879b6d8a (refs/remotes/origin/test_CI)
           > /usr/bin/git config core.sparsecheckout # timeout=10
           > /usr/bin/git checkout -f a2fa4a0cfae39d50d51d01d46190891f879b6d8a
           > /usr/bin/git rev-list 2b4d0c33e20ba201fd0896b75223555f005dde98 # timeout=10
          FATAL: hudson/tasks/Mailer$UserProperty
          java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
          at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
          at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
          at hudson.model.AbstractBuild.access$600(AbstractBuild.java:104)
          at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:619)
          at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
          at hudson.model.Run.execute(Run.java:1738)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:410)
          Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
          at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
          at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
          at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
          ... 13 more
          ERROR: Step ‘E-mail Notification’ aborted due to exception:
          java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
          at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
          at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
          at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:895)
          at hudson.tasks.MailSender.getChangeSet(MailSender.java:215)
          at hudson.tasks.MailSender.appendBuildUrl(MailSender.java:252)
          at hudson.tasks.MailSender.createFailureMail(MailSender.java:267)
          at hudson.tasks.MailSender.createMail(MailSender.java:180)
          at hudson.tasks.MailSender.run(MailSender.java:109)
          at hudson.tasks.Mailer.perform(Mailer.java:170)
          at hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:76)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
          at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
          at hudson.model.Build$BuildExecution.post2(Build.java:185)
          at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
          at hudson.model.Run.execute(Run.java:1763)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:410)
          Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
          at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
          at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
          at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
          ... 22 more
          FATAL: hudson/tasks/Mailer$UserProperty
          java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
          at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:77)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:71)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:48)
          at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
          at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:927)
          at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:895)
          at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:349)
          at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:672)
          at hudson.model.Run.execute(Run.java:1763)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:410)
          Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
          at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1376)
          at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
          at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
          ... 12 more
          Finished: FAILURE
          Environment Jenkins ver 1.638
          OS Centos
          mailer plugin 1.17
          Jenkins ver 1.638
          OS Centos
          mailer plugin 1.17
          Git plugin 2.2.9
          Git lab plugin 1.1.3
          madhukarreddy22 madhukar kasireddy made changes -
          Priority Minor [ 4 ] Critical [ 2 ]
          slide_o_mix Alex Earl added a comment -

          I'm not sure who the maintainer of the plugin is. You may want to hop on IRC and ask there. Have you recently upgraded any plugins?

          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 173396 ] JNJira + In-Review [ 185105 ]
          jglick Jesse Glick added a comment -

          Likely a plugin version mismatch or disabled plugin. Jenkins 2.19.x and later deals with this more clearly.

          jglick Jesse Glick made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Incomplete [ 4 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              madhukarreddy22 madhukar kasireddy
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: