Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36752

not able to launch ant in jenkins

    Details

    • Type: Story
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: ant-plugin
    • Labels:
      None
    • Environment:
      master on-CENTOS 7
      slave on-RHEL 6
    • Similar Issues:

      Description

      while compiling ant dist its not able to launch the ant and its giving error.

      error:
      $ ant dist
      Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tools/ant/launch/Launcher
      Caused by: java.lang.ClassNotFoundException: org.apache.tools.ant.launch.Launcher
      at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
      Could not find the main class: org.apache.tools.ant.launch.Launcher. Program will exit.
      Build step 'Invoke Ant' marked build as failure

      please check the issue and reply as soon as possible.
      and i tried setting both JAVA_HOME and ANT_HOME still giving the same error.

        Attachments

        1. ant_config.PNG
          ant_config.PNG
          20 kB
        2. auto_ant.PNG
          auto_ant.PNG
          16 kB
        3. screenshot-1.png
          screenshot-1.png
          20 kB
        4. Screen Shot 2016-07-18 at 15.03.15.png
          Screen Shot 2016-07-18 at 15.03.15.png
          94 kB

          Activity

          Hide
          build Niranjan Chougula added a comment - - edited

          actually its working well for few other projects in the master for this one only giving that problem...

          im running this project in the slave ....so tell me if any confiruration are required there???

          Show
          build Niranjan Chougula added a comment - - edited actually its working well for few other projects in the master for this one only giving that problem... im running this project in the slave ....so tell me if any confiruration are required there???
          Hide
          build Niranjan Chougula added a comment -

          im waiting for your solution!!!!!!!!!!

          Show
          build Niranjan Chougula added a comment - im waiting for your solution!!!!!!!!!!
          Hide
          armfergom Armando Fernandez added a comment -

          You can set the location of Ant Installation in your slave in the slave's configuration page. If you scroll all the way down and check "Tool Locations" you will see the option to add an Ant installation location for your slave.

          Show
          armfergom Armando Fernandez added a comment - You can set the location of Ant Installation in your slave in the slave's configuration page. If you scroll all the way down and check "Tool Locations" you will see the option to add an Ant installation location for your slave.
          Hide
          build Niranjan Chougula added a comment - - edited


          still same error

          Show
          build Niranjan Chougula added a comment - - edited still same error
          Hide
          jglick Jesse Glick added a comment -

          Use build.sh from Ant sources.

          Show
          jglick Jesse Glick added a comment - Use build.sh from Ant sources.

            People

            • Assignee:
              build Niranjan Chougula
              Reporter:
              build Niranjan Chougula
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: