Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36825

NoStaplerConstructorException with Jenkins 2.x+

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: filesystem_scm-plugin
    • Labels:
      None
    • Environment:
      filesystem_scm-plugin 1.20
      Jenkins 2.9+
    • Similar Issues:

      Description

      The plugin (1.20) is broken with Jenkins 2.9+.

      NoStaplerConstructorException: There's no @DataBoundConstructor on any constructor of class hudson.plugins.filesystem_scm.FSSCM

      on saving configuration.

      In fact in code the annotation is commented out.

        Attachments

          Activity

          emszpak Marcin Zajączkowski added a comment -

          Seems to be a regression fixed in Jenkins 2.12. Tested with 2.14 and works fine. Closing this issue.

          oleg_nenashev Oleg Nenashev added a comment -

          Yes, it was a regression. BTW Stapler constructor will be added as a part of JENKINS-40743


            People

            • Assignee:
              samngms samngms
              Reporter:
              emszpak Marcin Zajączkowski
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: