Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36855

BlueOcean Not Honoring Parameters For Pipeline Projects

    Details

    • Similar Issues:

      Description

      BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them.

      The failed build also won't show up in the BlueOcean pipeline queue, but it will in the standard Jenkins UI.

      In my case, it fails since the withEnv wrapper will be null.

      Build 11 started working again because I removed the withEnv function from my pipeline test. However, entries seem to have a significant delay when loading in the BlueOcean UI.

        Attachments

          Issue Links

            Activity

            ganthore Mark Austin created issue -
            ganthore Mark Austin made changes -
            Field Original Value New Value
            Description BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them. The failed build also won't show up the BlueOcean queue, but it will in the standard Jenkins UI. In my case, it fails since the withEnv wrapper will be null. BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them. The failed build also won't show up in the BlueOcean pipeline queue, but it will in the standard Jenkins UI. In my case, it fails since the withEnv wrapper will be null.
            ganthore Mark Austin made changes -
            Attachment snapshot4.jpeg [ 33395 ]
            Attachment snapshot5.jpeg [ 33396 ]
            Attachment snapshot6.jpeg [ 33397 ]
            ganthore Mark Austin made changes -
            Description BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them. The failed build also won't show up in the BlueOcean pipeline queue, but it will in the standard Jenkins UI. In my case, it fails since the withEnv wrapper will be null. BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them.

            !snapshot4.jpeg|thumbnail!

            The failed build also won't show up in the BlueOcean pipeline queue, but it will in the standard Jenkins UI.

            !snapshot5.jpeg|thumbnail!
            !snapshot6.jpeg|thumbnail!

            In my case, it fails since the withEnv wrapper will be null.

            ganthore Mark Austin made changes -
            Description BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them.

            !snapshot4.jpeg|thumbnail!

            The failed build also won't show up in the BlueOcean pipeline queue, but it will in the standard Jenkins UI.

            !snapshot5.jpeg|thumbnail!
            !snapshot6.jpeg|thumbnail!

            In my case, it fails since the withEnv wrapper will be null.

            BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them.

            !snapshot4.jpeg|thumbnail!

            The failed build also won't show up in the BlueOcean pipeline queue, but it will in the standard Jenkins UI.

            !snapshot5.jpeg|thumbnail!

            In my case, it fails since the withEnv wrapper will be null.

            ganthore Mark Austin made changes -
            Attachment snapshot6.jpeg [ 33397 ]
            ganthore Mark Austin made changes -
            Description BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them.

            !snapshot4.jpeg|thumbnail!

            The failed build also won't show up in the BlueOcean pipeline queue, but it will in the standard Jenkins UI.

            !snapshot5.jpeg|thumbnail!

            In my case, it fails since the withEnv wrapper will be null.

            BlueOcean will not prompt for parameters when you schedule a pipeline build that requires them.

            !snapshot4.jpeg|thumbnail!

            The failed build also won't show up in the BlueOcean pipeline queue, but it will in the standard Jenkins UI.

            !snapshot5.jpeg|thumbnail!

            In my case, it fails since the withEnv wrapper will be null.

            Build 11 started working again because I removed the withEnv function from my pipeline test. However, entries seem to have a significant delay when loading in the BlueOcean UI.

            jamesdumay James Dumay made changes -
            Link This issue relates to JENKINS-36059 [ JENKINS-36059 ]
            jamesdumay James Dumay made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 173601 ] JNJira + In-Review [ 199479 ]
            jamesdumay James Dumay made changes -
            Link This issue relates to JENKINS-36059 [ JENKINS-36059 ]
            jamesdumay James Dumay made changes -
            Comment [ Thanks for reporting. We are tracking this in JENKINS-36059. ]
            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-38490 [ JENKINS-38490 ]
            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-38490 [ JENKINS-38490 ]
            jamesdumay James Dumay made changes -
            Link This issue is duplicated by JENKINS-38494 [ JENKINS-38494 ]
            jamesdumay James Dumay made changes -
            Link This issue is duplicated by JENKINS-38494 [ JENKINS-38494 ]
            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-38494 [ JENKINS-38494 ]
            Hide
            jamesdumay James Dumay added a comment - - edited

            Mark Austin We are working on this feature right now as part of JENKINS-36855. Should be ready by mid-January 2017.

            Show
            jamesdumay James Dumay added a comment - - edited Mark Austin We are working on this feature right now as part of JENKINS-36855 . Should be ready by mid-January 2017.
            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-38494 [ JENKINS-38494 ]
            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-38805 [ JENKINS-38805 ]
            jbriden Jenn Briden made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                ganthore Mark Austin
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: